Ask Your Question
1

Disable VSync AMD Radeon (X vs Wayland)

asked 2018-12-08 21:30:23 -0500

For some reason when playing games (via Steam) it appears to be capped at 60fps. But only when using X; Wayland doesn't appear to make this happen.

I'm on Fedora 29 and have an RX 550. I'm guessing vsync is the cause, correct me if I'm wrong.

How can I make sure vsync is always off?

All tips, pointers, and suggestions welcome. My google-fu seems to turn up a lot of outdated info.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-12-17 07:53:25 -0500

SteveEbey73701 gravatar image

use export __GL_SYNC_TO_VBLANK=0 to set vsync off. X uses opengl to render with, so that should work.

edit flag offensive delete link more

Comments

No change. Thanks for the input though. I usually use Wayland all the time anyways; but was just testing some games in X to see if there was any advantage. So far it seems, no. But now I'm curious about the apparent cap/vsync issue.

suspiciousmilk gravatar imagesuspiciousmilk ( 2018-12-17 21:36:06 -0500 )edit

you might try export vblank_mode=0 to see if that works.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-12-18 16:29:39 -0500 )edit
0

answered 2018-12-15 20:28:06 -0500

ed209 gravatar image

If I remember correctly Wayland is actually capped at 60fps for the time being, not Xorg. Does the same behaviour happen with latest updates?

edit flag offensive delete link more

Comments

please quit posting questions as answers, it is getting annoying.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-12-17 07:50:00 -0500 )edit

So I should guess the kind of connection used, the specs of video card, the kernel used, Xorg version used, video display specs and so on? Very smart from you, indeed. You're annoying, and stop using downvotes. Since you're so smart. My computer doesn't work. What's wrong with Fedora? Answer without questions, please.

ed209 gravatar imageed209 ( 2018-12-17 08:56:08 -0500 )edit

is english your primary language? can you read, and comprehend what I wrote? I complained about you posting Questions in the Answer section and it confuses people into thinking you are answering the question that the person asked. It appears that the reason you post Questions as Answers, is to raise your karma value artificially, by posting in the Answer section. DO NOT POST A QUESTION TO THE OP IN THE ANSWER SECTION OF THE QUESTION, SINCE IT CONFUSES OTHERS INTO BELIEVING THE QUESTION BEING ASKED HAS BEEN ANSWERED, AND IN TRUTH ALL YOU HAVE DONE IS ASKED MORE QUESTIONS.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-12-17 17:20:46 -0500 )edit

Yeah, still happens. Wayland (Gnome) is good, X is capped. I've not done anything (on purpose anyways) that would effect this. I've tried KDE, Gnome, and Openbox in X. KDE even has a tick box in its control panel to disable vsync (not that it made a difference). I usually don't use KDE/Plasma, just installed it for testing purposes. The only "tweaking" I've done on my system is activating zram and adjusting my swapiness, which neither should affect vsync. Reset those back to default to test just in case (no change as expected).

suspiciousmilk gravatar imagesuspiciousmilk ( 2018-12-17 21:34:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-08 21:30:23 -0500

Seen: 122 times

Last updated: Dec 17 '18