Ask Your Question
1

Opera don't work with Fedora KDE 29

asked 2018-12-09 19:12:07 -0500

rigbyk3 gravatar image

Hi, have installed opera from UnitedRPMs with command (superuser):

dnf install opera

but never open, when run the command (no super user): opera in terminal show this:

 /usr/lib64/opera/opera: error while loading shared libraries: libffmpeg.so: cannot open shared object file: No such file or directory

when do:

cd /usr/lib64/opera/opera && ls

show the files and there is libffmpeg.so, why no detect it?

What can do?

edit retag flag offensive close merge delete

Comments

1

Does running it like this: LD_LIBRARY_PATH=/usr/lib64/opera/opera opera work?

fcomida gravatar imagefcomida ( 2018-12-09 20:34:59 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2018-12-14 17:47:23 -0500

davidva gravatar image

Well, the first action when you find a problem from UnitedRPMs is open a bug report HERE. I recommend you to use the correct ways; I as you, who will to see bug reports here?

Other, the issue is alredy solved; then...

su
dnf clean all && dnf -y update

Wiki

edit flag offensive delete link more
0

answered 2018-12-10 20:34:50 -0500

updated 2019-01-16 01:34:09 -0500

A. it's another way to down load rpm file with opear website for fedora and redhat package.

http://www.opera.com
https://www.opera.com/download/get/?partner=www&opsys=Linux&package=RPM
http://download3.operacdn.com/ftp/pub

B. install rpm package

# rpm -Uvh opera-stable_57.0.3098.91_amd64.rpm 
Updating / installing...
1:opera-stable-57.0.3098.91-0      ################################# [100%]

C. it's a show stable use and no trouble in Fedora29S KDE System, check ffmpeg installation status.

# rpm -qa|grep ffmpeg
ffmpeg-libs-4.0.3-1.fc29.x86_64
ffmpeg-devel-4.0.3-1.fc29.x86_64
ffmpeg-4.0.3-1.fc29.x86_64

orion opera]# pwd
/usr/lib64/opera
opera]# ls
icudtl.dat        opera_100_percent.pak      opera_crashreporter
libEGL.so         opera_125_percent.pak      opera_sandbox
libGLESv2.so      opera_150_percent.pak      resources
libffmpeg.so      opera_200_percent.pak      setup_repo.sh
localization      opera_250_percent.pak      snapshot_blob.bin
natives_blob.bin  opera_autoupdate           swiftshader
opera             opera_autoupdate.licenses  v8_context_snapshot.bin
opera.pak         opera_autoupdate.version

D. in case, unstable set or different, input your home configuration like a commet "fcomida"

# vi .bashrc
LD_LIBRARY_PATH=/usr/lib64/opera/opera opera

E. Opera Web Brower stable also simple and very fast run in linux System. Now, this Web Brower OPERA tested in Fedora29S..written by simmon

edit flag offensive delete link more
0

answered 2018-12-11 08:55:49 -0500

erichanif gravatar image

Hello,

Can you try this :

1 - Install libXScrnSaver

2 - Download the last RPM file from the Opera site (https://www.opera.com/download/get/?p...)

3 - From the terminal, go to in the directory where the RPM file is downloaded and install it (example: sudo dnf install opera-stable_57.0.3098.91_amd64.rpm)

Bye

(post a feedback if it works)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-09 19:12:07 -0500

Seen: 177 times

Last updated: Jan 16