Ask Your Question
1

New hard disk - Grub always boots into emergency mode

asked 2018-12-10 00:55:29 -0500

furtelwart gravatar image

updated 2018-12-10 02:36:14 -0500

I attached a new SATA hard disk. Since then, Grub always entered into emergency mode. If I detach the hard disk, Fedora boots without problems. When I logged in and then attach the new disk again, I can access the disk.

My setup is the following:

  • one SSD containing the OS and grub
  • one hard drive containing /home/
  • the new hard disk

BIOS detects the disks correctly and the boot priority is also correct. Grub is even listing all OS correctly. It's an old BIOS, so no UEFI.

Booting Windows 10 via Grub works fine.

Can you tell me how that happens and what I might do? Thanks in advance!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-12-10 07:31:53 -0500

furtelwart gravatar image

I switched the SATA ports and now the problem is gone.

edit flag offensive delete link more

Comments

OK..THAT'S GOOD^^

simmon gravatar imagesimmon ( 2018-12-10 07:33:43 -0500 )edit
0

answered 2018-12-10 02:02:02 -0500

updated 2018-12-20 22:02:59 -0500

A. check..sata port and boot list for your bios system, it's a another boot list mixed..new disk more fast boot list than installed linux partition. all so, ssd sometime it's a make trouble like that UEFI system

B. No UEFI, Dual Boot in system...wanted a another add a disk..for linux mount size extend for home folder disk status check...and it's a compatible for linux?

a. grub2 make some trouble because of partition table mixed....
b. do you have usb to sata hdd mobile case for check system in normal boot and status ssd?
c. how is first boot system ? 
d. check booting table use fdisk. sometimes disk modified partition....unintentionally..!!

C. new hard disk.....you are need to check new hard disk....how is new hard disk check partition table... My Fedora29S KDE Dual Disk System also Windows7 - stable just use like you bios mode no UEFI

I think that 's easily add hard disk...in boot and correct bios boot list, so it' a reason bios find a new disk than pre-installation disk or grub2 confused new disk

another way....disk not mixed different operating system in one disk. it can be switch mode to other disk boot. mixted disk interfere other system... [win boot and linux boot]

C. home mount system.. for extend new disk for your system, copy other folder..and link or mount..it's a more stable use rsync...command and /etc/fstab update for your new boot system.

 $ sudo mount /dev/mapper/aaa-bbb /homesys
 $ sudo rsync -avz /home /homesys

 then mount new disk [/dev/sdb1] or xfs file system /dev/mapper/aaa-bbb
 /etc/fstab input for home directory...for reboot system mount

 * xfs file system
 mount /dev/mapper/aaa-bbb /homesys  xfs defaults 0 0

 * ext4 file system
  mount  /dev/sdb1  /homesys ext4 defaults 0 0

D. it's doesn't effect....or some trouble, booting progress show problem typing [ctrl +D] input password..fix mount location for new home folder and using a terminal mode.

written by simmon

edit flag offensive delete link more

Comments

It's hard for me to understand your answer(s). What do you mean with "another boot list mixed"? I don't have any problems with mounting my current home folder. It's the new (empty) hard disk which makes problems.

furtelwart gravatar imagefurtelwart ( 2018-12-10 02:37:23 -0500 )edit

new hard disk.....you are need to check new hard disk....how is new hard disk check partition table...

simmon gravatar imagesimmon ( 2018-12-10 02:53:46 -0500 )edit

I formatted the hard disk with ext4, one primary partition, GUID partition table.

furtelwart gravatar imagefurtelwart ( 2018-12-10 03:23:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-10 00:55:29 -0500

Seen: 114 times

Last updated: Dec 20 '18