Ask Your Question
1

No sound Intel NUC8I7HVK - fedora29

asked 2018-12-10 13:59:14 -0500

etzior gravatar image

updated 2018-12-17 10:57:12 -0500

I am dual booting Fedora 29 and Windows 10 on Intel NUC Hades Canyon (NUC8I7HVK). I have 5.1 speakers connected to audio combo jack. On Windows sound works normally. I have tried to make it work Fedora 29 too, but so far with no success. I have installed Pulse Audio Control Panel and checked different setup in configuration tab. Most of them is unplugged or marked as HDMI. Unluckily, I still cannot hear anything. Can somebody guide me how to enable it? I am not so experienced user.

I have two jack's front and rear (which works for both analog and digital sound). When I plug in jack from headphones (analog). In settings -> sound appera option: Built-in sound -> Headphones (front jack) / Line (rear jack) and profile: Analog Duplex Stereo. Problem appears when I connect 5.1 speakers with digital cable TOSLINK to JACK. No option available in settings -> sound - only HDMI / DisplayPort 6 - HD-Audio Generic, profile: Out Digital Stereo (HDMI 6) - which I guess that is my monitor connected to DisplayPort.

Debug:

  1. Result of : alsa-info.sh --no-upload : https://pastebin.com/wKmYTrbJ
  2. Removing PulseAudio didn't help.
  3. alsamixer -c0 : screen
  4. Subsystem id from alsa-info: 8086:2073 - couldn't find more information in web

Result of command: dmesg|grep sound :

 [   21.615737] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input27
 [   21.615794] input: HD-Audio Generic HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input28
 [   21.615843] input: HD-Audio Generic HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input29
 [   21.615898] input: HD-Audio Generic HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input30
 [   21.616194] input: HD-Audio Generic HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input31
 [   21.616244] input: HD-Audio Generic HDMI/DP,pcm=11 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input32
 [   21.684426] input: HDA Intel PCH Line Out as /devices/pci0000:00/0000:00:1f.3/sound/card0/input33
 [   21.684470] input: HDA Intel PCH Front Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input34
 [   21.684521] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input35
 [   21.684588] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input36
 [   21.684655] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input37
 [   21.684704] input: HDA Intel PCH HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input38
 [   21.684747] input: HDA Intel PCH HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input39 ...
(more)
edit retag flag offensive close merge delete

Comments

thanks...I see a you message for sound messages.. fedora knows hardware ..with a good status. plz, check system setting in sound part.sound-Configure the Audio Volume-advanced, Let me know set status in profile ? .

simmon gravatar imagesimmon ( 2018-12-12 22:46:31 -0500 )edit

I can see one device: HDMI / DisplayPort6-HD-Audio Generic. Profile is set to Out Digital Stereo (HDMI 6) - cannot change it to anything else.

etzior gravatar imageetzior ( 2018-12-13 00:03:39 -0500 )edit

Ok..let's try to change other set in profile... !!

simmon gravatar imagesimmon ( 2018-12-13 00:10:00 -0500 )edit

There is no other option to change. Only when I connect bluetooth headset appears new device and it works fine (2 profiles available for headset). When I pick HDMI / DisplayPort6-HD-Audio Generic there is no list with profiles on click. Just Out Digital Stereo (HDMI 6). I have installed rpmfusion too. No new options. I have also found useful command: alsa-info.sh --no-upload . In file generated by it there is information that my Jack has status Running - No. Maybe change it will help. Do you know how can I do it? I will paste information in next comment due to limitation of characters.

etzior gravatar imageetzior ( 2018-12-13 00:18:47 -0500 )edit

!!Sound Servers on this system !!----------------------------

Pulseaudio: Installed - Yes (/usr/bin/pulseaudio) Running - Yes

Jack: Installed - Yes (/usr/bin/jackd) Running - No

If you need I can paste whole file generated by this command, but it is quite long.

etzior gravatar imageetzior ( 2018-12-13 00:40:52 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-12-12 11:30:59 -0500

updated 2019-01-04 08:24:34 -0500

A. Intel NUC Support Linux System & BIOS Document

 NUC sound system : On-board audio - Codec chip     Intel Display Audio 

 https://www.intel.com/content/www/us/en/support/articles/000005499/mini-pcs.html
 https://www.intel.com/content/dam/support/us/en/documents/mini-pcs/BIOSGlossary_NUC.pdf
 https://www.intel.com/content/www/us/en/support/articles/000030985/mini-pcs.html

B. trouble list in NUC [ document mentioned but, it's a case F20 ]

 HDMI audio isn't working on Fedora 20*
 Update the kernel of Fedora 20 to the latest version (3.14.8 or later) to resolve this problem.

C. Plz, search and check your system use a "dmesg|grep sound", show me a your system status? Sound Support your board samples for sound status in boot progress

 $ sudo dmesg|grep sound
 input: HDA Intel PCH Dock Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input17
 input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input18
 input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input19
 input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input20
 input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input21

D. check system settings - Multimedia - Audio / Audio and Video

[Fedora System good support Audio and Video Hardware ]

 Audio Volume : check Advanced - Profile
 Audio and Video : Default Audio Playback Device Preference

E. Audio and Video Support Program and Library Install for Fedora

 rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-29.noarch.rpm

F. Sound setting for check KDE Hardware Program.

 rpm -qa|grep phonon
 phonon-qt5-4.10.1-2.fc29.x86_64
 phonon-qt5-backend-gstreamer-4.9.0-9.fc29.x86_64
 phonon-backend-gstreamer-4.9.0-9.fc29.x86_64
 phonon-qt5-backend-vlc-0.9.1-6.fc29.x86_64
 phonon-devel-4.10.1-2.fc29.x86_64
 phonon-4.10.1-2.fc29.x86_64
 phonon-backend-vlc-0.9.1-6.fc29.x86_64

 # aplay -l
**** List of PLAYBACK Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CX20590 Analog [CX20590 Analog]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0

G. pulseaudio and alsa, and install the program and library

#  dnf groupupdate Multimedia
#  dnf install libasound* portaudio* alsa*
#  dnf install phonon-qt5*

written by simmon

edit flag offensive delete link more

Comments

Thank you for helping me. I have updated question with result of command: dmesg|grep sound

etzior gravatar imageetzior ( 2018-12-12 22:10:30 -0500 )edit

I have the same issue with NUC8i3BEK. Sound volume extremely low on digital output! Can't find a solution yet.

rvgestel gravatar imagervgestel ( 2019-01-04 04:21:36 -0500 )edit

Add additional libraries and more for sound settings.

simmon gravatar imagesimmon ( 2019-01-04 08:37:40 -0500 )edit
0

answered 2018-12-16 17:05:51 -0500

ed209 gravatar image

Goto Settings -> Sound then select the proper device, that should read Line Out. Raise the volume in order to hear the speakers test. Does HDMI output also work?

edit flag offensive delete link more

Comments

Only option available in settings -> sound is: HDMI / DiplsayPort 6 - HD-Audio Generic and profile: Out Digital Stereo (HDMI 6). I can't hear anything through speakers. When I plug in headphones into front jack new option apears: Headphones - Built-in sound and profile: Out Analog Stereo. It works. I have installed pavucontrol to have more options and went through all of them - none worked. They are described in post with question.

etzior gravatar imageetzior ( 2018-12-16 18:02:46 -0500 )edit

I've read your description, but I want to understand what is seen in Gnome. To recap, the stereo jack works, while HDMI doesn't. Your hardware is this one: https://is.gd/tyhXKy . You could debug your problem using this guide: https://fedoraproject.org/wiki/How_to...

ed209 gravatar imageed209 ( 2018-12-16 20:15:24 -0500 )edit

I have updated post by going through steps in debug guide which you sent me. Yes, hardware is this one. Problem is not with HDMI. I have two jack's - front and rear. Rear can work with both analog and digital cables. Problem appears when I connect digital cable (TOSLINK to JACK) - I have also updated description in my question to make it more precise. HDMI / DiplsayPort 6 - HD-Audio Generic and profile: Out Digital Stereo (HDMI 6) in settings -> sound is my monitor connected to DisplayPort, but I don't need to use it.

etzior gravatar imageetzior ( 2018-12-17 10:36:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-12-10 13:59:14 -0500

Seen: 645 times

Last updated: Jan 04