Ask Your Question
1

Can't update glibc

asked 2018-12-12 11:35:00 -0500

fasulia gravatar image

It's been about a week that glibc updates have been skipped, apparently due to no glibc-headers package being available for version 2.27-35.fc28.i686.

 Problem 1: cannot install both glibc-headers-2.27-35.fc28.x86_64 and glibc-headers-2.27-32.fc28.x86_64
  - glibc-headers-2.27-32.fc28.i686 has inferior architecture
  - cannot install the best update candidate for package glibc-headers-2.27-32.fc28.x86_64
  - problem with installed package glibc-headers-2.27-32.fc28.i686
 Problem 2: package glibc-headers-2.27-32.fc28.i686 requires glibc = 2.27-32.fc28, but none of the providers can be installed
  - cannot install both glibc-2.27-35.fc28.i686 and glibc-2.27-32.fc28.i686
  - cannot install both glibc-2.27-35.fc28.x86_64 and glibc-2.27-32.fc28.x86_64
  - cannot install the best update candidate for package glibc-headers-2.27-32.fc28.i686
  - cannot install the best update candidate for package glibc-2.27-32.fc28.i686
  - cannot install the best update candidate for package glibc-2.27-32.fc28.x86_64
================================================================================
 Package              Arch          Version                Repository      Size
================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 glibc                i686          2.27-35.fc28           updates        3.4 M
 glibc                x86_64        2.27-35.fc28           updates        3.6 M
 glibc-headers        x86_64        2.27-35.fc28           updates        460 k

Transaction Summary
================================================================================
Skip  3 Packages

Nothing to do.
Complete!
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2019-02-03 23:35:34 -0500

fasulia gravatar image

This was never fixed in Fedora 28, and has a status of "can't fix" in a bug report: https://bugzilla.redhat.com/show_bug....

The proposed workaround is to remove glibc-headers.i686

Upgrading to Fedora 29 sees this issue go away.

edit flag offensive delete link more
1

answered 2018-12-12 12:39:34 -0500

fcomida gravatar image

It's a bug: 1658497

edit flag offensive delete link more

Comments

I'm surprised to see a bug for such a critical system component. At least I know I just have to wait for a fix.

fasulia gravatar imagefasulia ( 2018-12-12 12:47:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-12 11:35:00 -0500

Seen: 190 times

Last updated: Feb 03