Ask Your Question
1

How do I get my desktop power supply configured on my workstation?

asked 2018-12-12 19:26:55 -0500

Fedora thinks my desktop is a laptop. It only shows a battery, which I don't have. The nonexistent battery is discharging.

How do I fix this?

edit retag flag offensive close merge delete

Comments

HI...welcome this fedora forum....Have a nice day!!! how is your system... Mainboard or other else like a gui [gnome or kde...or mate]?

simmon gravatar imagesimmon ( 2018-12-13 00:04:07 -0500 )edit
1

Don't you by chance use bluetooth mouse or keyboard? Some time ago I've had battery icon showing status/charge level of my wireless keyboard's battery.

Night Romantic gravatar imageNight Romantic ( 2018-12-13 03:53:30 -0500 )edit

probably.....it's could be...sometimes...like a workstation. also i am use to be a wireless mouse and bluetooth keyboard...in thnikpad. My System tested in ThinkPad with laptop and IBM Server that's a no show error with a Fedora29 Server

simmon gravatar imagesimmon ( 2018-12-13 07:09:03 -0500 )edit

Thanks for the feedback It shows that there is an AC Power Supply and it is not on.

hedidin gravatar imagehedidin ( 2018-12-13 20:57:54 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-12-13 00:39:08 -0500

updated 2018-12-14 21:24:22 -0500

A. system run in and check process upower daemon and system-settings-power

Bug report like that F25..upower problem...https://bugzilla.redhat.com/show_bug.cgi?id=1398826
Fedora workstation run in battery power management in default system.
https://fedoraproject.org/wiki/Changes/ImprovedLaptopBatteryLife

B. install package for PowerManagement program and other library for stable system.

 dnf install kf5*
 kf5* will support and it'll be reload power management start working for stable run.
 tlp and powertop run in you system? plz, check....for battery management...for run in fake..

C. you can use power managemt in system-setting

 Power Management - disable battery run.un-mark all for your system, just use On AC Power

D. Fedora is largely divided into Server and Workstation,which are the power-related default settings for the server. For stable operation, it is recommended to stop the operation if the power related battery is set.

It's a checked ibm server in Fedora29S, it's show no trouble in Fedora29 Server system written by simmon

edit flag offensive delete link more

Comments

I tried B. first. Rebooted and still have the same issue. C. Under Settings, Power Management doesn't exist. Only Power and there are no settings to change anything.

Actually, I installed Server first. I work with Docker quite a bit. I installed the desktop on top of the server.

hedidin gravatar imagehedidin ( 2018-12-13 21:07:32 -0500 )edit

As I asked, I am using Fedora servers for Laptop ThinkPad T420 and Testing Server IBM X3550M2, the laptop automatically grabs battery manager, and after verifying the IBM server as a test server, I have confirmed that the power manager does not work. The two Fedora servers installed the KDE GUI in a terminal environment, and each system did not cause any problems with the battery.

probably...it may be installed something wrong some program or do not support your hardware system in fedora.

simmon gravatar imagesimmon ( 2018-12-13 22:35:53 -0500 )edit

I tried it with Debian. It was recognized.

hedidin gravatar imagehedidin ( 2018-12-14 19:41:20 -0500 )edit

Fedora29 - Dell/IBM/Intel...ThinkPad...good work my system also, need more stability for your system. Centos7 - Debian 9 also can be improve your stability...have a fun and enjoy. Have a nice day!. written bysimmon

simmon gravatar imagesimmon ( 2018-12-14 21:22:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-12 19:26:55 -0500

Seen: 72 times

Last updated: Dec 14 '18