Ask Your Question
1

nvidia gtx 1050

asked 2018-12-13 04:24:41 -0600

benpack gravatar image

Hello,

I have installed F29 workstation 64-bit from a DVD. In the beginning it worked without problem, but now after a few minutes the display is almost freezing with a very delayed response on mouse action, it is not possible to work.

No Nvidia specific additional drivers were installed, 'dnf update' has run .

When selecting the internal graphics of the i7-6700 in the BIOS, F29 runs stable as usual with it. But this is only a worakround since with the other OS the GTX 1050 needs to be used.

What is the experience and recommendation:

Will there be an F29 update in the next future which fixes the problem

or install the Nvidia drivers from their side

or follow the https://negativo17.org/nvidia-driver/

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2018-12-13 04:55:41 -0600

Night Romantic gravatar image

updated 2018-12-13 04:56:18 -0600

I've used F28 with 1050 Ti without installing NVidia proprietary drivers (i.e. with free nouveau driver) without any problem. But right before upgrade to F29 (i.e. in F28) and after upgrading (i.e. in F29) I had the same problem you describe.

So it can be some sort of regression in nouveau itself or some other graphics-related package. If anyone has some definitive info regarding this regression - please tell us.

I've chosen to install proprietary drivers from negativo's repo. I also used his repo in the past (around F24-26 and with older card model), can vouch for it from my own experience.

You have two more alternatives for installing proprietary drivers.

One is "offical" way:

sudo dnf config-manager --set-enabled rpmfusion-nonfree-nvidia-driver

This is a "subsection" of rpmfusion repo containing Nvidia drivers. It's included in F29, but disabled by default.

Second way is enabling whole of rpmfusion repo. Then you can follow their howto: https://rpmfusion.org/Howto/NVIDIA. Also you can read this FedoraMagazine article - though I like rpmfusion's howto more, article suggests some unnecessary steps, see discussion in comments if interested.

I've used rpmfsuion's drivers too, they're ok (and even sort of suggested by Fedora since F28).

Two major differences between them and negativo's I found:

  1. Negativo provides only latest version of the drivers, that doesn't support older Nvidia chipsets (that's not your case).

  2. With current rpmfusion drivers you can use Wayland. In negativo's build you can't (won't dive into additional details, tell if you need them).

edit flag offensive delete link more

Comments

Also you can try some nouveau kernel settings in grub like "nouveau.modeset=0". I now can't say for sure, I think I tried it on F28 after I had this glitch and it haven't helped... but I can be wrong)

As I think about this more, with my computer problem could have started after upgrade to kernel 4.19 (in F28). Worked ok with 4.18. But I'm not 100% sure now)

Night Romantic gravatar imageNight Romantic ( 2018-12-13 05:01:14 -0600 )edit

See also this report at bugzilla. Reporter also have Nvidia GP107 (which is GTX 1050), and their description of the problem matches closely my own experience.

But they've stated that

> The bug SEEMS to have disappeared with the release of kernel-4.19.5-200.

and closed the bugreport.

@benpack, does bugreport's problem description match what you see on your machine?

Do you have latest kernel installed and running? If not by any chance, I strongly suggest to update, reboot and see if the problem persists.

Night Romantic gravatar imageNight Romantic ( 2018-12-13 06:27:27 -0600 )edit

@benpack, I've verified yesterday evening that my home desktop with GTX 1050 still have this problem with nouveau driver 100% reproducible with all the latest available stable (not testing) updates. It's kernel 4.19.8-300 and xorg-x11-drv-nouveau version 1:1.0.15-6.

So for the time being I think your best bet to get stable gnome desktop is to install proprietary Nvidia driver.

Night Romantic gravatar imageNight Romantic ( 2018-12-14 01:06:39 -0600 )edit

I also had a 'black screen' problem at log in with a GTX 650 a few months ago, but that has disappered now.

It will be interesting to know which Card / GPUs are still affected like the GTX 1050 is.

benpack gravatar imagebenpack ( 2018-12-14 04:45:56 -0600 )edit

I have now installed the Nvidia driver from the rpmfusion repo following their HowTo, although the GTX1050 is not among the supported chips in the list of the link (outdated ?). F29 runs stable now, I have used half a day FreeCad.

benpack gravatar imagebenpack ( 2018-12-21 10:50:48 -0600 )edit
0

answered 2018-12-13 10:54:36 -0600

benpack gravatar image

First of all: Many thanks for all the hints and comments.

I have updated the system this morning: kernel 4.19.6 xorg-x11-drv-nouveau 1.0.15

I am not sure if it is unpredictable: There is always normal working directly after boot, but within a few minutes there are delays going to more or less freezing. A few days ago the cursor was corrupted with some bright pixels moving when moving the mouse.

Since Wayland is currently default as far as I know, rpmfusion seems to be the best way, using

sudo dnf config-manager --set-enabled rpmfusion-nonfree-nvidia-driver

edit flag offensive delete link more

Comments

You understand of course that this command only enables repository with NVidia drivers, you have to install them afterwards, instructions are in rpmfusion's HowTo or/and in the article i linked to in my answer.

Night Romantic gravatar imageNight Romantic ( 2018-12-14 01:09:38 -0600 )edit

Of course .

benpack gravatar imagebenpack ( 2018-12-14 04:40:27 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-12-13 04:24:41 -0600

Seen: 104 times

Last updated: Dec 13 '18