Ask Your Question
0

No sound in gnome-boxes

asked 2018-12-15 18:59:10 -0600

teodoro777 gravatar image

I can't hear sound from every box created in gnome boxes, independently of operating system. For example, my last box is centos, when I go in gnome settings, trying to fix the sound, the only output is "dummy".

This is a screenshot: image description

Is this a bug?

PS I already tried to install spice-gtk, but nothing is changed.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-12-18 18:13:16 -0600

FeRDNYC gravatar image

updated 2018-12-18 18:27:41 -0600

I hit this same issue, setting up a Windows guest. And I can't for the life of me find any of the web resources I looked up to find the solution. But, at least in my case, the issue was the ancient AC97 sound hardware that the VMs were configured with by default, which resulted in the guest needing some out-of-date sound driver that never worked.

As indicated in this answer, the sound device ich6 was properly detected by Windows (when all others weren't), and as I recall that was all it took to get sound working for me. I don't recall doing any of the crazy stuff in the 'Audio output' section of Fedora wiki's virtualization page.

if you run virsh list --all in a terminal, you'll see a list of the configured virtual machines, and virsh edit <name> will launch an editor to modify the configuration of the named guest. Unfortunately I no longer have the original text from before I modified it, but I edited the <sound... definition in there to read:

<sound model='ich6'>
  <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
</sound>

<graphics type='spice'>
  <listen type='none'/>
  <image compression='off'/>
</graphics>

And as you can see I'm using Spice instead of VNC for display (since according to /etc/libvirt/qemu.conf)...

# QEMU implements an extension for providing audio over a VNC connection,
# though if your VNC client does not support it, your only chance for getting
# sound output is through regular audio backends. By default, libvirt will
# disable all QEMU sound backends if using VNC, since they can cause
# permissions issues. Enabling this option will make libvirtd honor the
# QEMU_AUDIO_DRV environment variable when using VNC.
#
#vnc_allow_host_audio = 0

(I have not had to enable vnc_allow_host_audio in my setup.)

With ich6 as the sound device emulation and <graphics type='spice'> for display, I have working, problem-free sound on both Windows and Fedora guests.

ETA: Opening up virt-manager and pulling up the hardware details for a guest, if I select the audio device there's a "Model:" dropdown that allows me to select among the various emulated sound devices. And I see that in addition to ich6 there's also the newer ich9, which I'm tempted to try. But, if editing the XML directly seems daunting, that's another way to go.

image description

edit flag offensive delete link more
0

answered 2018-12-15 19:58:20 -0600

ed209 gravatar image

Are you sure the relevant volume on the host is not muted?

edit flag offensive delete link more

Comments

Yes, I'm sure, but you can see yourself from screenshot.

teodoro777 gravatar imageteodoro777 ( 2018-12-16 05:16:09 -0600 )edit

No, I see the guest settings running centos, NOT Fedora.

ed209 gravatar imageed209 ( 2018-12-16 11:11:49 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-15 18:59:10 -0600

Seen: 43 times

Last updated: Dec 18 '18