Ask Your Question
5

Can't update hplip

asked 2018-12-17 15:05:09 -0500

fasulia gravatar image

updated 2019-01-06 21:13:58 -0500

EDIT: This issue is now resolved with the update to hplip version 3.18.6-12.fc28.


First it was glibcnot getting updated (still not solved: https://ask.fedoraproject.org/en/ques... ). Now hplip and related packages have a problem with a missing dependency version.

libnetsnmp.so.35()(64bit) is required, but the package net-snmp-libs currently provides libnetsnmp.so.30()(64bit).

This is all still on Fedora 28. What's going on with so many broken updates lately?

 Problem 1: cannot install the best update candidate for package hplip-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-3.18.6-11.fc28.x86_64
 Problem 2: cannot install the best update candidate for package hplip-libs-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-libs-3.18.6-11.fc28.x86_64
 Problem 3: cannot install the best update candidate for package libsane-hpaio-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by libsane-hpaio-3.18.6-11.fc28.x86_64
 Problem 4: package hplip-gui-3.18.6-11.fc28.x86_64 requires libsane-hpaio(x86-64) = 3.18.6-11.fc28, but none of the providers can be installed
  - cannot install the best update candidate for package hplip-gui-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by libsane-hpaio-3.18.6-11.fc28.x86_64
 Problem 5: cannot install both glibc-headers-2.27-35.fc28.x86_64 and glibc-headers-2.27-32.fc28.x86_64
  - glibc-headers-2.27-32.fc28.i686 has inferior architecture
  - cannot install the best update candidate for package glibc-headers-2.27-32.fc28.x86_64
  - problem with installed package glibc-headers-2.27-32.fc28.i686
 Problem 6: package hplip-libs-3.18.6-10.fc28.x86_64 requires hplip-common(x86-64) = 3.18.6-10.fc28, but none of the providers can be installed
  - cannot install both hplip-common-3.18.6-11.fc28.x86_64 and hplip-common-3.18.6-10.fc28.x86_64
  - problem with installed package hplip-libs-3.18.6-10.fc28.x86_64
  - cannot install the best update candidate for package hplip-common-3.18.6-10.fc28.x86_64
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-libs-3.18.6-11.fc28.x86_64
 Problem 7: package glibc-headers-2.27-32.fc28.i686 requires glibc = 2.27-32.fc28, but none of the providers can be installed
  - cannot install both glibc-2.27-35.fc28.i686 and glibc-2.27-32.fc28.i686
  - cannot install both glibc-2.27-35.fc28.x86_64 and glibc-2.27-32.fc28.x86_64
  - cannot install the best update candidate for package glibc-headers-2.27-32.fc28.i686
  - cannot install the best update candidate for package glibc-2.27-32.fc28.i686
  - cannot install the best update candidate for package glibc-2.27-32.fc28.x86_64
================================================================================
 Package              Arch          Version                Repository      Size
================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 glibc                i686          2.27-35.fc28           updates        3.4 M
 glibc                x86_64        2.27-35.fc28           updates        3.6 M
 glibc-headers        x86_64        2.27-35.fc28           updates        460 k
 hplip-common         x86_64        3.18.6-11.fc28         updates        110 k
Skipping packages with broken dependencies:
 hplip                x86_64        3.18.6-11.fc28         updates         16 M
 hplip-gui            x86_64        3.18.6-11.fc28         updates        1.3 M
 hplip-libs           x86_64        3.18.6-11.fc28         updates        204 k
 libsane-hpaio        x86_64        3.18.6-11.fc28         updates        127 k ...
(more)
edit retag flag offensive close merge delete

Comments

plz check...i686 & X86 mixed your system....you may be able to resolve the issue by installing the appropriate package or resolving the mixed state.

simmon gravatar imagesimmon ( 2018-12-17 21:56:20 -0500 )edit

remove the glibc.i686, your system seems to be x86_64.

florian gravatar imageflorian ( 2018-12-18 09:33:47 -0500 )edit

Removing glibc.i686 would remove 191 packages: https://paste.fedoraproject.org/paste/YJL~tI0LbV2uKegwLYAowA

fasulia gravatar imagefasulia ( 2018-12-18 20:24:41 -0500 )edit

I am say to check i686 and X86 system to show and hardware matching status, and I see your post..

no...it's to make a some trouble...glibc still use i686 library..and share other program.

just install hplip and hplib-gui, and run # hp-setup, before it's a ready to install qt5 library.

plz. do not remove glibc.

simmon gravatar imagesimmon ( 2018-12-19 00:15:44 -0500 )edit

What do you mean by "check i686 and X86 system"? No worries, I won't be uninstalling glibc!

fasulia gravatar imagefasulia ( 2018-12-19 12:23:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-12-17 18:16:21 -0500

florian gravatar image

updated 2018-12-17 18:17:24 -0500

Don't worry - this is simply because of (temporarily) unsolved dependencies. The essential error message from the above is:

nothing provides libnetsnmp.so.35()(64bit) needed by hplip-3.18.6-11.fc28.x86_64

Here are different ways to solve the problem:

1.) You wait until the dependencies are solved in Fedora repos

or

2.) you use the fedora-testing repo to update the package net-snmp-libs that is solving the required dependency:

sudo dnf update --enablerepo=updates-testing hplip*
edit flag offensive delete link more

Comments

Thanks. Yes, waiting seems like the best option. I'm again surprised that such issues exist at all in a stable distro by the lack of coordination in package and dependency updates.

fasulia gravatar imagefasulia ( 2018-12-17 18:20:09 -0500 )edit

Fixed with update to hplip version 3.18.6-12.fc28. Patience has paid off.

fasulia gravatar imagefasulia ( 2019-01-06 21:16:38 -0500 )edit

@fasulia, well, for Fedora 28 it did - but it is already months after Fedora 29 is released... quite an delay ...

hxunbanned gravatar imagehxunbanned ( 2019-01-17 02:51:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-17 15:05:09 -0500

Seen: 1,065 times

Last updated: Jan 06