Ask Your Question
0

System boot order not found. Initializing defaults

asked 2018-12-21 08:35:48 -0500

verlioca gravatar image

Hello everyone! Coming to you with the hope for assistance. :)

I have a HP laptop, which came with preinstalled Windows 10. Alongside it I installed Fedora 27 in dual boot back in spring. No problem there, upgraded twice (to F28 and then to F29.

Now I wanted to try and replace the native HDD with SSD. So I replaced it, again no problem. I decided to install Fedora 29 as a single system on this SSD. No issue as well, although it didn't ask me to create a root password (F27 did). Since the SSD was brand new and empty, I let the installer do the partitioning in automatic mode.

However, there is a nuisance. When I booted on the previous HDD, it showed me GRUB menu with ability to select Windows or older cores for Fedora. Now at about the same place it shows me the following: "System boot order not found. Initializing defaults". It stays for about 5 seconds, then the system goes on to boot, the rest is usual up to the welcome screen.

efibootmgr -v gives me only one boot entry (labelled 0000).

I suspect something is not quite right with UEFI, although I didn't change anything from the previous setup. And when I put the HDD back in it boots again with GRUB menu, no swearing about system boot order.

What is this? It boots alright, but why does it show me this message? What does it want from me? :)

Thanks in advance for your advice!

edit retag flag offensive close merge delete

Comments

On a couple of occasions I was able to see grub on reboot. It listed two or three kernels and a rescue option. Is there a way to make it always visible? Will it solve the "system boot order" warning?

verlioca gravatar imageverlioca ( 2018-12-29 02:58:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-02-09 06:09:49 -0500

verlioca gravatar image

I've found a solution, can't believe I didn't think of it sooner.

Turns out, it is a known HP issue due to their bad implementation of UEFI. So I went to BIOS settings and invoked the Customised Boot option: put it at the beginning of the boot order and gave it path to Fedora efi file.

Now it loads directly to Fedora, no BootOrder errors.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-21 08:35:48 -0500

Seen: 490 times

Last updated: Dec 21 '18