Ask Your Question
0

Update error

asked 2018-12-23 07:10:49 -0500

Ildar gravatar image

updated 2018-12-25 05:18:56 -0500

hhlp gravatar image

I found the following error. After attempting the update. I used the following construction:

sudo dnf upgrade --refresh

I received the following information about conflicts:

Ошибка: Ошибка при проверке транзакции:
  файл /usr/share/doc/gstreamer1/NEWS из устанавливаемого пакета gstreamer1-1.12.5-1.fc27.i686 конфликтует с файлом из пакета gstreamer1-1.12.4-1.fc27.x86_64
  файл /usr/share/doc/gstreamer1/RELEASE из устанавливаемого пакета gstreamer1-1.12.5-1.fc27.i686 конфликтует с файлом из пакета gstreamer1-1.12.4-1.fc27.x86_64
  файл /usr/share/locale/lt/LC_MESSAGES/pulseaudio.mo из устанавливаемого пакета pulseaudio-libs-12.2-1.fc27.i686 конфликтует с файлом из пакета pulseaudio-libs-12.0-3.fc27.x86_64
  файл /usr/share/doc/libpcap/CHANGES из устанавливаемого пакета libpcap-14:1.9.0-1.fc27.i686 конфликтует с файлом из пакета libpcap-14:1.8.1-7.fc27.x86_64
  файл /usr/share/doc/libpcap/CREDITS из устанавливаемого пакета libpcap-14:1.9.0-1.fc27.i686 конфликтует с файлом из пакета libpcap-14:1.8.1-7.fc27.x86_64
  файл /usr/share/man/man7/pcap-filter.7.gz из устанавливаемого пакета libpcap-14:1.9.0-1.fc27.i686 конфликтует с файлом из пакета libpcap-14:1.8.1-7.fc27.x86_64
  файл /usr/share/man/man7/pcap-linktype.7.gz из устанавливаемого пакета libpcap-14:1.9.0-1.fc27.i686 конфликтует с файлом из пакета libpcap-14:1.8.1-7.fc27.x86_64
  файл /usr/share/man/man7/pcap-tstamp.7.gz из устанавливаемого пакета libpcap-14:1.9.0-1.fc27.i686 конфликтует с файлом из пакета libpcap-14:1.8.1-7.fc27.x86_64
  файл /usr/share/gcc-7/python/libstdcxx/__init__.pyc из устанавливаемого пакета libstdc++-7.3.1-6.fc27.i686 конфликтует с файлом из пакета libstdc++-7.3.1-5.fc27.x86_64
  файл /usr/share/gcc-7/python/libstdcxx/__init__.pyo из устанавливаемого пакета libstdc++-7.3.1-6.fc27.i686 конфликтует с файлом из пакета libstdc++-7.3.1-5.fc27.x86_64
  файл /usr/share/gcc-7/python/libstdcxx/__pycache__/__init__.cpython-36.opt-1.pyc из устанавливаемого пакета libstdc++-7.3.1-6.fc27.i686 конфликтует с файлом из пакета libstdc++-7.3.1-5.fc27.x86_64
  файл /usr/share/gcc-7/python/libstdcxx/__pycache__/__init__.cpython-36.pyc из устанавливаемого пакета libstdc++-7.3.1-6.fc27.i686 конфликтует с файлом из пакета libstdc++-7.3.1-5.fc27.x86_64
  файл /usr/share/gcc-7/python/libstdcxx/v6/__init__.pyc из устанавливаемого пакета libstdc++-7.3.1-6.fc27.i686 конфликтует с файлом из пакета libstdc++-7.3.1-5.fc27.x86_64
  файл /usr/share/gcc-7/python/libstdcxx/v6/__init__.pyo из устанавливаемого пакета libstdc++-7.3.1-6.fc27.i686 конфликтует с файлом из пакета libstdc++-7.3.1-5.fc27.x86_64
  файл /usr/share/gcc-7/python/libstdcxx/v6/__pycache__/__init__.cpython-36.opt-1.pyc из устанавливаемого пакета libstdc++-7.3.1-6.fc27.i686 конфликтует с файлом из пакета libstdc++-7.3.1-5.fc27.x86_64
  файл /usr/share/gcc-7/python/libstdcxx/v6/__pycache__/__init__.cpython-36.pyc из устанавливаемого пакета libstdc++-7.3.1-6.fc27.i686 конфликтует с файлом из пакета libstdc++-7.3.1-5.fc27.x86_64
  файл /usr/share/gcc-7/python/libstdcxx/v6/__pycache__/printers.cpython-36.opt-1.pyc из устанавливаемого пакета libstdc++-7.3.1-6.fc27.i686 конфликтует с файлом ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-12-24 05:43:58 -0500

Glenn gravatar image

You appear to be mixing i686 packages with X86_64 packages. That could indicate that you've altered your dnf repositories. If so, that needs to be resolved. Post the result of the following commands please:

uname -ra
dnf repolist
edit flag offensive delete link more

Comments

Really need it ?

duckfern gravatar imageduckfern ( 2018-12-24 10:06:10 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-23 07:10:49 -0500

Seen: 47 times

Last updated: Dec 24 '18