Fedora 29: Failed to start Switch Root when using PXE

asked 2018-12-24 05:54:51 -0600

akiross gravatar image

updated 2018-12-24 09:06:15 -0600

I got the Fedora WS live DVD (from here), then set up dnsmasq to boot from network with PXE. I am currently seeing the syslinux bootloader.

My PXE server is not connected to a network, so I want to boot the PXE client using the DVD ISO, so I also set up a nginx server that serves the content of the ISO (mounted on loopback).

The kernel is booting with: vmlinuz initrd=initrd.img inst.stage2=http://192.168.2.1/ inst.repo=http://192.168.2.1 (I found details on inst.repo here).

The problem is that, when booting, it fails with the message

Failed to start Switch Root

and journalctl says that

Failed to switch root: Specified switch root path '/sysroot/' does not seem to be an OS tree. os-release file is missing

What is this message and how do I fix it?

Edit

After RTFM, I managed to specify the root option almost correctly, and I booted with:

vmlinuz initrd=initrd.img inst.stage2=http://192.168.2.1/ inst.repo=http://192.168.2.1 ip=dhcp root=live:http://192.168.2.1/LiveOS/squashfs.img

where squashfs.img is the 1.9 GB root system used in the Live image. The system finally boots, but it is not the usual live image, as I have no options to install the system on the hard drive, so I think the options are still not completely correct.

edit retag flag offensive close merge delete