Ask Your Question
1

fedora 29, downgrade gcc 8.2 to 7.3

asked 2018-12-25 07:16:06 -0600

Anton Voznia gravatar image

I have fedora 29 and I need downgrade gcc from 8.2 to 7.3 (it is needed for CUDA).

dnf --releasever=27 install gcc-7.3.1-6.fc27

Is not working. I got the error:

Error: Failed to synchronize cache for repo 'fedora-modular'

How to do it?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2018-12-25 12:41:52 -0600

villykruse gravatar image

Try

dnf --releasever=27 --disablerepo=fedora-modular --disablerepo=updates-modular downgrade gcc

This may or may not work, and if it doesn't work I would suggest to install Fedora27 in a virtual machine, as this is a cleaner solution.

edit flag offensive delete link more

Comments

The command is working for me, thx.

Anton Voznia gravatar imageAnton Voznia ( 2018-12-25 14:06:07 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-12-25 07:16:06 -0600

Seen: 70 times

Last updated: Dec 25 '18