Ask Your Question

Error when inserting user in a group

asked 2018-12-27 11:57:32 -0600

bionan2017 gravatar image

When I try to insert a user into a group with the command:

sudo usermod -a -G bobgroup nginx

I get the following error message:

[sss_cache] [confdb_get_domains] (0x0010): No domains configured, fatal error! Could not open available domains usermod: sss_cache exited with status 2 usermod: Failed to flush the sssd cache.

Thanks for any help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-12-28 07:38:04 -0600

Samuel Jaeschke gravatar image

In my case it was because SSSD was installed but not configured.

SSSD is used for connecting your Fedora system to a domain (such as LDAP or Active Directory) so that any user accounts on a domain can be used to log into your Fedora system. This is typically used in a corporate or university environment. If this were your situation then SSSD would have been configured by your network administrator, and you probably wouldn't be managing user groups locally.

If you aren't using SSSD or domain accounts on your system, you can safely remove it like so:

sudo dnf remove sssd

_This fixed the problem for me. I'm not sure how/why SSSD got installed to begin with though. I ran into it immediately after upgrading to Fedora 29, which seems like an interesting coincidence._

edit flag offensive delete link more


Thank you, Sir! Problem solved!

bionan2017 gravatar imagebionan2017 ( 2018-12-29 03:10:45 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2018-12-27 11:57:32 -0600

Seen: 285 times

Last updated: Dec 27 '18