Ask Your Question
1

Fedora 29 on my Lenovo thinkpad W540 freezes randomly

asked 2019-01-04 22:02:17 -0500

askfilm gravatar image

I use Fedora 29 on my thinkpad W540. The system freezes randomly and back to normal after a few seconds, I've had this sever times per hours, it's so boring.

I have seen this Bug: #1571330 , but I don't know it will be useful: "try booting with ahci.mobile_lpm_policy=0 kernel command line." I do not know how to do it . please help me , tell me how to do.

edit retag flag offensive close merge delete

Comments

cpu i7-4800MQ , Nvidia Quadro K1100m , Intel® Haswell Mobile / NVE7

askfilm gravatar imageaskfilm ( 2019-01-05 04:08:16 -0500 )edit

1 Answer

Sort by ┬╗ oldest newest most voted
1

answered 2019-02-01 13:02:21 -0500

BennyS gravatar image

Hello,

I've the same issue with my W540.

Just edit the following file with root rights:

sudo vim /etc/default/grub

and add "ahci.mobile_lpm_policy=0" in the GRUB_CMDLINE_LINUX:

for example: GRUB_CMDLINE_LINUX=" {...} ahci.mobile_lpm_policy=0 rhgb quiet"

Then you need to rebuild grub (depends on UEFI or not)

UEFI

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

BIOS:

grub2-mkconfig -o /boot/grub2/grub.cfg

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-01-04 22:02:17 -0500

Seen: 110 times

Last updated: Feb 01