Help with Python(abi)

asked 2019-01-23 09:21:00 -0600

I've installed the latest Python 2.7 and Python3 but when I try to install Odoo 12, I get this message

warning: odoo_12.0.latest.noarch.rpm: Header V4 RSA/SHA256 Signature, key ID 8183cbb5: NOKEY Error: Failed dependencies:
python(abi) = 3.6 is needed by odoo-12.0.post20181127-1.noarch

Any help please to resolve this! Thanks

edit retag flag offensive close merge delete

Comments

I suggest to learn how to use pyenv (https://github.com/pyenv/pyenv). It's available via copr: https://copr.fedorainfracloud.org/coprs/nili/pyenv/

vmercuri gravatar imagevmercuri ( 2019-01-23 17:26:40 -0600 )edit

How did you install Python? It's possible you've installed some python3 version less than 3.6. It's also possible that while you've installed python3.6, you're using an older version of python in this particular scenario. As is pointed out above, pyenv is a great tool. However, in this particular scenario, where you want to run a service, virtualenvmight be a more reliable scenario (I've run into problems running webapps with pyenv). https://virtualenv.pypa.io/en/latest/ (pyenv is a wrapper around virtualenv for convenience in the terminal)

connorbode gravatar imageconnorbode ( 2019-01-24 06:29:20 -0600 )edit