Ask Your Question
1

Fedora 29 Everything netinstall fails.

asked 2019-01-26 05:26:35 -0500

infin1te gravatar image

I'm trying to do a minimal install of Fedora on my PC in UEFI mode alongside Windows 10.

Everything is fine in the installer, but after it finishes and I reboot my pc, the entry for Fedora in GRUB is missing. Windows has an entry and works perfectly fine.

After a little investigation, I noticed that there is no vmlinuz in /boot ( initramfs image is there ). I tried copying the kernel image from the netinstall USB and running grub2-mkconfig from chroot. Once I do that, Fedora appears in GRUB and it seems to boot, but then systemd runs into problems, something about /etc/machine-id.

edit retag flag offensive close merge delete

Comments

This happened to me also. Another user had the same problem with the server netinstall, except he couldn't boot at all not having a Windows installation ready to rely on (I was left with an entry for Windows as well, but I didn't bother to understand what was going on and ended up installing Fedora from the MATE Live iso). If you can give more details then I'd suggest to file a bug-report.

vmercuri gravatar imagevmercuri ( 2019-01-26 10:21:02 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-01-27 21:24:49 -0500

Reinhardt gravatar image

I started today without any problems.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-01-26 05:26:35 -0500

Seen: 70 times

Last updated: Jan 26