Changing Cups on Fedora to block cover page

asked 2019-01-28 10:21:45 -0600

updated 2019-02-03 07:24:52 -0600

hhlp gravatar image

Hi we recently installed CUPS on solaris 10, and fixed an issue where every print job printed a cover page, no matter what the settings were, by updating a cups.xml file

vi /lib/svc/manifest/application/cups.xml

Search for cups-lpd line and add “-o job-sheets=none

Due to issues with the version of CUPS, we created a fedora 28 server and installed CUPS on it instead, but...we have the same issue with the cover page. Does anyone know what the equivalent on fedora is to do the above and block all cover pages?

edit retag flag offensive close merge delete

Comments

my brother laser printer does not print cover pages, so it may be that the printer driver is the problem, and not cups. Have you seen anything in the printer properties that talks about a cover page?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2019-01-30 07:31:27 -0600 )edit

Hi, If I print from the command line on the fedora server then it doesn't print a cover page. It is only when I am sending a print to the cups printer on the fedora server from a different server that the cover page prints. I have multiple printers setup at various sites around Europe and it is the same on all of them. They already print without a cover page via on older cups server, it appears to be the newer versions of CUPS that display this issue. I need the location of where the lp command is for cups to add on the job-sheets=none option to stop this behaviour. Thanks

Lou.Colsey gravatar imageLou.Colsey ( 2019-02-01 05:22:38 -0600 )edit

Just to add on, in CUPS all the printers have the option for job-sheets set to none. I have checked all the conf files etc, and everything is as it should be!

Lou.Colsey gravatar imageLou.Colsey ( 2019-02-01 05:25:16 -0600 )edit