Ask Your Question
1

After upgrading to Fedora 29 4.20.3, GUI is not launching. Instead the OS starts in terminal(CLI) mode only. Is there any way to permanently resolve this?

asked 2019-01-29 00:03:18 -0600

Rohan gravatar image

updated 2019-02-03 07:25:32 -0600

hhlp gravatar image

Recently, I updated Fedora from 4.19.10 to 4.20.3 build. But post upgrade, the system launches only in terminal mode. I tried to enable gdm using following command- systemctl enable lightdm.service. This did not help. startx command works but it requires manual execution on each reboot. Is there a way to permanently fix this issue?

edit retag flag offensive close merge delete

Comments

What is the output of

systemctl get-default
villykruse gravatar imagevillykruse ( 2019-01-29 01:28:48 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-01-29 05:21:46 -0600

clnetbox gravatar image

updated 2019-01-29 05:26:37 -0600

Eventually the default setting has been changed.
Current setting seems to be multi-user.target.

To boot in GUI mode execute these commands.
GUI mode will be the default setting afterwards.

sudo systemctl set-default graphical.target  
sudo reboot
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-01-29 00:03:18 -0600

Seen: 97 times

Last updated: Jan 29