dnf tab autocompletion broken for package names after update (Fedora 29)

asked 2019-02-04 00:29:24 -0500

fasulia gravatar image

updated 2019-02-18 00:55:49 -0500

Tab autocompletion works for dnf options, but not for package names. It appears to freeze the command line and I have to hit Ctrl-C twice to get back the command prompt.

I have bash-completion and sqlite packages installed.

Autocompletion used to work on Fedora 28, and this issue started after upgrading to Fedora 29.


Observations on dnf package name tab completion

  • does not work for my user
  • works for root
  • does not work after dnf install or dnf info
  • works after dnf remove (including for my user)

EDIT Using sudo strace -pXXXX -tfo /tmp/strace.log (where XXXX is the process ID of the bash terminal where tab completion is being attempted) from here generated a 9MB 80k+ line log file and attached 55 processes. Suggestions of what hints to look for in there?

edit retag flag offensive close merge delete

Comments

It works on my F29 box, both for dnf options as well as packages.

florian gravatar imageflorian ( 2019-02-04 02:58:28 -0500 )edit

Any idea what I should check? All I know is it used to work on F28 and it no longer does immediately after the update to F29.

fasulia gravatar imagefasulia ( 2019-02-04 03:03:24 -0500 )edit

Try reinstalling bash-completion maybe that fixes some dependency (you need sqlite3 in order for the tab completion to work): sudo dnf install reinstall bash-completion

florian gravatar imageflorian ( 2019-02-04 03:15:01 -0500 )edit

You could also take a look at this Q/A, it could be a similar issue.

florian gravatar imageflorian ( 2019-02-04 03:22:29 -0500 )edit

I already tried reinstalling bash-completion and sqlite (that installs sqlite3, there is no package called sqlite3). Does your system have /etc/bash_completion.d/dnf-completion.bash as mentioned here? Mine does not.

fasulia gravatar imagefasulia ( 2019-02-04 03:36:31 -0500 )edit