Ask Your Question
0

Fedora 29 Bluetooth Mouse (Dell WM524)

asked 2019-02-05 22:03:51 -0500

johnnywiller gravatar image

Hi, I'm trying to setup a bluetooth mouse, without success.

Bluetoothctl shows connect/disconnect every second.

Mouse works, I've tested on a windows machine.

Bellow, some traces:

Bluez installed: bluez-5.50-3.fc29.src.rpm (Bluez 5.50 x86_74)

sudo hcitool info 00:1F:20:8E:20:CE
Requesting information ...
    BD Address:  00:1F:20:8E:20:CE
    OUI Company: Logitech Europe SA (00-1F-20)
    Device Name: Dell Travel Mouse WM524
    LMP Version: 3.0 (0x5) LMP Subversion: 0x2211
    Manufacturer: Broadcom Corporation (15)
    Features page 0: 0xbc 0x04 0x82 0x78 0x00 0x06 0x59 0x83
        <encryption> <slot offset> <timing accuracy> <role switch> 
        <sniff mode> <channel quality> <paging scheme> 
        <broadcast encrypt> <enhanced iscan> <interlaced iscan> 
        <interlaced pscan> <inquiry with RSSI> <sniff subrating> 
        <pause encryption> <extended inquiry> <simple pairing> 
        <encapsulated PDU> <non-flush flag> <LSTO> <inquiry TX power> 
        <extended features> 
    Features page 1: 0x01 0x00 0x00 0x00 0x00 0x00 0x00 0x00

Bluetooth Status

 systemctl status bluetooth:

● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2019-02-06 01:05:47 -02; 18min ago
     Docs: man:bluetoothd(8)
 Main PID: 821 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 4915)
   Memory: 2.6M
   CGroup: /system.slice/bluetooth.service
           └─821 /usr/libexec/bluetooth/bluetoothd

Feb 06 01:06:03 localhost.localdomain bluetoothd[821]: RFCOMM server failed for Message Notification: socket(STREAM, RFCOMM): Protocol not supported (93)
Feb 06 01:06:03 localhost.localdomain bluetoothd[821]: RFCOMM server failed for Message Access: socket(STREAM, RFCOMM): Protocol not supported (93)
Feb 06 01:06:03 localhost.localdomain bluetoothd[821]: RFCOMM server failed for Phone Book Access: socket(STREAM, RFCOMM): Protocol not supported (93)
Feb 06 01:06:03 localhost.localdomain bluetoothd[821]: RFCOMM server failed for Synchronization: socket(STREAM, RFCOMM): Protocol not supported (93)
Feb 06 01:06:03 localhost.localdomain bluetoothd[821]: RFCOMM server failed for File Transfer: socket(STREAM, RFCOMM): Protocol not supported (93)
Feb 06 01:06:03 localhost.localdomain bluetoothd[821]: RFCOMM server failed for Object Push: socket(STREAM, RFCOMM): Protocol not supported (93)
Feb 06 01:07:01 localhost.localdomain bluetoothd[821]: Can't open HIDP control socket
Feb 06 01:07:02 localhost.localdomain bluetoothd[821]: Rejected connection from unknown device 00:1F:20:8E:20:CE
Feb 06 01:13:04 localhost.localdomain bluetoothd[821]: Can't open HIDP control socket
Feb 06 01:13:09 localhost.localdomain bluetoothd[821]: connect error: Host is down (112)

With bluetoothctl I can pair the device:

[bluetooth]# pair 00:1F:20:8E:20:CE 
Attempting to pair with 00:1F:20:8E:20:CE
[CHG] Device 00:1F:20:8E:20:CE Connected: yes
[CHG] Device 00:1F:20:8E:20:CE Modalias: usb:v046DpB00Ed0800
[CHG] Device 00:1F:20:8E:20:CE UUIDs: 00001000-0000-1000-8000-00805f9b34fb
[CHG] Device 00:1F:20:8E:20:CE UUIDs: 00001124-0000-1000-8000-00805f9b34fb
[CHG] Device 00:1F:20:8E:20:CE UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device 00:1F:20:8E:20:CE ServicesResolved: yes
[CHG] Device 00:1F:20:8E:20:CE Paired: yes ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-03-20 02:08:07 -0500

I hit the same problem with the following setup:

  • Lenovo ThinkPad 460s with Fedora 29
  • Lenovo ThinkPad Bluetooth Laser Mouse

I paired the mouse via _Bluetooth_ settings menu. Then I got "Connect/Disconnect every second" issue once the mouse or the laptop goes off/on.

My procedure to fix it was:

  1. Open _Terminal_
  2. bluetoothctl
  3. remove the mouse, if it is paired

    [bluetooth]# paired-devices
    Device 98:FD:B4:75:1B:39 ThinkPad Bluetooth Laser Mouse
    
    [bluetooth]# remove 98:FD:B4:75:1B:39
    [DEL] Device 98:FD:B4:75:1B:39 ThinkPad Bluetooth Laser Mouse
    Device has been removed
    
  4. turn on pairing on the mouse

    [bluetooth]# scan on
    Discovery started
    [NEW] Device 98:FD:B4:75:1B:39 ThinkPad Bluetooth Laser Mouse
    
    [bluetooth]# scan off
    Discovery stopped
    
  5. trust the device (the device is still in pairing mode)

    [bluetooth]# trust 98:FD:B4:75:1B:39
    [CHG] Device 98:FD:B4:75:1B:39 Trusted: yes
    Changing 98:FD:B4:75:1B:39 trust succeeded
    
  6. pair the device and connect

    [bluetooth]# pair 98:FD:B4:75:1B:39
    Attempting to pair with 98:FD:B4:75:1B:39
    [CHG] Device 98:FD:B4:75:1B:39 Connected: yes
    [CHG] Device 98:FD:B4:75:1B:39 Modalias: usb:v17EFp6038d0200
    [CHG] Device 98:FD:B4:75:1B:39 UUIDs: 00001000-0000-1000-8000-00805f9b34fb
    [CHG] Device 98:FD:B4:75:1B:39 UUIDs: 00001124-0000-1000-8000-00805f9b34fb
    [CHG] Device 98:FD:B4:75:1B:39 UUIDs: 00001200-0000-1000-8000-00805f9b34fb
    [CHG] Device 98:FD:B4:75:1B:39 ServicesResolved: yes
    [CHG] Device 98:FD:B4:75:1B:39 Paired: yes
    Pairing successful
    [CHG] Device 98:FD:B4:75:1B:39 ServicesResolved: no
    [CHG] Device 98:FD:B4:75:1B:39 Connected: no
    
    [bluetooth]# connect 98:FD:B4:75:1B:39
    Attempting to connect to 98:FD:B4:75:1B:39
    [CHG] Device 98:FD:B4:75:1B:39 Connected: yes
    Connection successful
    [CHG] Device 98:FD:B4:75:1B:39 ServicesResolved: yes
    [CHG] Device 98:FD:B4:75:1B:39 ServicesResolved: no
    [CHG] Device 98:FD:B4:75:1B:39 Connected: no
    [CHG] Device 98:FD:B4:75:1B:39 Class: 0x00000580
    [CHG] Device 98:FD:B4:75:1B:39 Icon: input-mouse
    [CHG] Device 98:FD:B4:75:1B:39 Connected: yes
    
edit flag offensive delete link more
0

answered 2019-02-06 09:29:00 -0500

johnnywiller gravatar image

what a lucky, I just tried [bluetooth]# trust 00:1F:20:8E:20:CE and worked!

But I've tried this before without success, the difference is now I tried to trust when the mouse is on pairing mode... This seems to have a huge difference.

If I trust without in the pairing mode, nothing happens.

Anyway, thank you guys!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-02-05 22:03:51 -0500

Seen: 121 times

Last updated: Feb 05