Ask Your Question
0

F29 won't boot after failed hibernation

asked 2019-02-06 01:29:07 -0500

nickwp gravatar image

My laptop (Dell XPS 9365) running Fedora 29 recently attempted to hibernate due to low battery, but it seems the battery ran out at some point during the process, and now it fails to resume and then fails to boot. Rescue mode also fails to start in the same way:

The first error during boot, after waiting a while, is:

Timed out waiting for device dev-mapper-fedora\x2dswap.device
Dependency failed for Resume from hibernation using device /dev/mapper/fedora-swap

Then, after waiting a bit longer, a large number of the following errors:

dracut-initqueue[376]: Warning: dracut-initqueue timeout - starting timeout scripts

Then eventually it reaches the emergency shell with:

Warning: /dev/fedora/root does not exist
Warning: /dev/fedora/swap does not exist
Warning: /dev/mapper/fedora-root does not exist
Generating "/run/initramfs/rdsosreport.txt"
Entering emergency mode. Exit the shell to continue.
Type "journalctl" to view system logs.
You might want to save "/run/initramfs/rdsosreport.txt" to a USB stick or /boot
after mounting them and attach it to a bug report
dracut:/#

In this shell there seems to be very little I can do. When exiting I get the additional messages:

dracut-initqueue[376]: Warning: Not all disks have been found.
dracut-initqueue[376]: Warning: You might want to regenerate your initramfs.

From within this shell, the dracut command is not recognised so I can't regenerate initramfs using that. Unfortunately I also don't have any way to copy the rdsosreport.txt file or other logs off the laptop.

I don't have any experience debugging anything to do with initramfs or dracut... Is there anything I can do to try to rescue the system, without having to reinstall from scratch and lose my data?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-02-09 09:50:42 -0500

rdtcustomercare gravatar image

take usb stick, boot from it, find you swap partition and execute as root :

mkswap /dev/....swapdevicename...

should remove the hibernation signature from swap.

edit flag offensive delete link more
0

answered 2019-02-09 20:55:13 -0500

nickwp gravatar image

It turns out that somehow the BIOS settings had reset, with the disk set to RAID mode instead of AHCI. Changing back to AHCI allowed the drive to be recognised and Fedora booted fine. It even resumed from hibernation.

edit flag offensive delete link more

Comments

good to know.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-10 14:28:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-02-06 01:29:07 -0500

Seen: 183 times

Last updated: Feb 09