Ask Your Question
1

Fedora 29: Temporarily disabling nvidia drivers for enabling the intel chip

asked 2019-02-06 07:57:16 -0500

Canberk Sönmez gravatar image

I am working on an HP laptop with a GTX1050 graphics card (+optimus) and Fedora 29 (x86_64). I have been trying to install Nvidia drivers, and I have gone through several guides, including this one, which failed.. Finally, I found out that using negativo17 fedora-nvidia repo really works. I simply installed the necessary the necessary files, and, they I was! The problem now, however, is disabling the nvidia driver. What can I do to disable the nvidia driver and use Intel graphics instead? By the way, I have tried to modbrobe.blacklist the nvidia related kernel modules, but this somehow caused enabling nouveau, which doesn't work at all. (even though it was in the blacklist as well).

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2019-02-06 17:33:44 -0500

FedoraPrime is one solution; another is outlined here.

FedoraPrime required enabling the rpmfusion repository then the proprietary driver repository. Details and explanations are provided here.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-02-06 07:57:16 -0500

Seen: 206 times

Last updated: Feb 06