Ask Your Question
0

Cannot connect mobile as MTP device

asked 2019-02-07 02:35:21 -0500

starchyme gravatar image

When pluggin my phone to my computer and setting it as an MTP device, I get this error:

The file or folder udi=/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:13.2/usb2/2-1 does not exist.

The MTP connectivity feature worked 100% in prior versions of Fedora. From 28, it gave this problem

edit retag flag offensive close merge delete

Comments

It looks like a KDE problem. Se for example.

villykruse gravatar imagevillykruse ( 2019-02-07 02:58:20 -0500 )edit

it seems to be the case. thanks. will monitor.

starchyme gravatar imagestarchyme ( 2019-02-07 04:38:48 -0500 )edit

FWIW when I have problems with MTP s work around is to install a ftp server on the phone.

Panther gravatar imagePanther ( 2019-02-07 08:49:12 -0500 )edit

@Panther: That is indeed interesting. but will not install ftp server on my phone at this stage. if it does indeed work, it would be fascinating to see how it is fixed from a phone's perspective and not fedora's

starchyme gravatar imagestarchyme ( 2019-02-08 03:17:46 -0500 )edit

I again suggest a ftp server on the phone. It is trivial to install and you then connect via wireless. When not in use turn ftp server off. They really are easier to use, I fought with MTP for way too long

Panther gravatar imagePanther ( 2019-02-08 11:38:26 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-02-08 03:05:13 -0500

Glenn gravatar image

Check status of the packages gvfs-mtp and simple-mtpfs. There have been instances for me where these packages needed to be installed and system rebooted before I could successfully connect my phone.

edit flag offensive delete link more

Comments

found simple-mtpfs was not installed. installing it and rebooting the machine fixed the problem.

starchyme gravatar imagestarchyme ( 2019-02-08 03:47:41 -0500 )edit

Note, that after plugging the phone out and back in and trying to remount. the same conditions returned. another option now appears to mount as "camera:" ... but you can only view/read . not write. So this solution only worked once, then it subverted back to the original problem.

starchyme gravatar imagestarchyme ( 2019-02-08 03:59:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-02-07 02:35:21 -0500

Seen: 73 times

Last updated: Feb 08