Ask Your Question
0

Failed to activate service 'org.freedesktop.fwupd': timed out

asked 2019-02-08 04:28:14 -0500

Łukasz Taraszka gravatar image

Hello,

I've updated my Fedora 29 and a following error message appears in the settings window:

Error calling StartServiceByName for org.freedesktop.fwupd: GDBus.Error:org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.freedesktop.fwupd': timed out (service_start_timeout=25000ms)

I also noticed that the same error appears when I run command:

fwupdmgr get-updates

Can anyone help me deal with this problem?

edit retag flag offensive close merge delete

Comments

"systemctl status fwupd" or "journalctl -xe" will give you more infos. Add those here pls.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-09 09:56:25 -0500 )edit

I have the same issue look the results from the comands you provided:

journalctl -xe fev 13 09:35:02 localhost.localdomain org.gnome.Shell.desktop[14129]: libinput error: client bug: timer event3 debounce short: offset negative (-3ms)

systemctl status fwupd fwupd.service - Firmware update daemon Loaded: loaded (/usr/lib/systemd/system/fwupd.service; static; vendor preset: disabled) Active: active (running) since Wed 2019-02-13 08:02:06 -03; 1h 36min ago Docs: https://fwupd.org/ Main PID: 14688 (fwupd) Tasks: 5 (limit: 4915) Memory: 20.5M CGroup: /system.slice/fwupd.service └─14688 /usr/libex

josectheone gravatar imagejosectheone ( 2019-02-13 06:39:41 -0500 )edit

@Josec: systemd thinks your fwupd runs fine. if you can see it with "ps auxf| grep fwupd | grep -v grep" (removes grep line from output to avoid confusion :) ) systemd seems to have handled the startup ok. This also means, that i can't help you anymore here.

BUT: I had a problem with tomcat a few days ago, where systemd status showed a healty running daemon, but there wasn't one running. IF ps auxf|grep fwupd .... does not return a running process, you should open a bugreport against systemd, because theire status-call() does not work proper.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-24 10:21:55 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-04-11 00:21:01 -0500

I've seen this happen on a new install of Fedora 29 after package fwupd is updated from version 1.1.2 (ships with Fedora) to 1.2.6. Check your log via journalctl -u fwupd and look for an error message like this:

fwupd[2563]: Failed to load engine: Failed to alter database: duplicate column name: checksum_device

To fix this, remove the bad file via sudo rm /var/lib/fwupd/pending.db then restart the service with sudo systemctl start fwupd. If corrected, sudo systemctl status fwupd will report:

Active: active (running)

and the error message in Gnome (gdbus) will go away.

edit flag offensive delete link more

Comments

FYI, pending.db is a history database, so it is not critical. Also, the fwupd developer has added code to delete the history file if corruption is detected, so manually deleting the file should not be necessary after Fedora packages fwupd version 1.2.7.

Sam Yoder gravatar imageSam Yoder ( 2019-04-11 10:30:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-02-08 04:28:14 -0500

Seen: 596 times

Last updated: Feb 08