Ask Your Question
0

How to install swift jabber client on fedora 28?

asked 2019-02-11 05:53:26 -0500

AnatolijNowak gravatar image

updated 2019-02-11 05:54:31 -0500

When i try to install it, i got this error

[root@ivory vodolaz095]# dnf install swift
Last metadata expiration check: 1:23:14 ago on Mon 11 Feb 2019 01:26:02 PM MSK.
Error: 
 Problem: conflicting requests
  - nothing provides libboost_system.so.1.64.0()(64bit) needed by swift-3.0-0.12.rc2.fc27.x86_64

I installed system-boost

[root@ivory vodolaz095]# dnf install boost-system

// some data not important

Installed:
  boost-system.x86_64 1.66.0-8.fc28                                                                                                                             

Complete!

But i got the same error

[root@ivory vodolaz095]# dnf install swift
Last metadata expiration check: 1:23:14 ago on Mon 11 Feb 2019 01:26:02 PM MSK.
Error: 
 Problem: conflicting requests
  - nothing provides libboost_system.so.1.64.0()(64bit) needed by swift-3.0-0.12.rc2.fc27.x86_64

How can i install it?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-02-11 12:14:45 -0500

ATM you can't, as someone forgot to update the Swift Package to the new boost version.

Pls open a bugreport for it @ https://bugzilla.redhat.com

BUT: you can always go to koji and get an OLD F27 boost-system rpm and install it instead of the new one. It's not recommended, but could get you to a result.

https://koji.fedoraproject.org/koji/

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-02-11 05:53:26 -0500

Seen: 38 times

Last updated: Feb 11