pvcreate fail in anaconda

asked 2019-02-15 03:29:21 -0500

updated 2019-02-16 04:53:51 -0500

hhlp gravatar image

anaconda 27.20.4-1 exception report
Traceback (most recent call first):
File "/usr/lib64/python3.6/site-packages/gi/overrides/BlockDev.py", line 824, in wrapped
raise transform[1](msg)
File "/usr/lib/python3.6/site-packages/blivet/formats/lvmpv.py", line 125, in _create
blockdev.lvm.pvcreate(self.device, data_alignment=self.data_alignment)
File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
return m(*args, **kwargs)
File "/usr/lib/python3.6/site-packages/blivet/formats/__init__.py", line 511, in create
self._create(**kwargs)
File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 45, in run_with_lock
return m(*args, **kwargs)
File "/usr/lib/python3.6/site-packages/blivet/deviceaction.py", line 607, in execute
options=self.device.format_args)

File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 472, in start
self.run_task()
File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
item.start()
File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
item.start()
File "/usr/lib64/python3.6/site-packages/pyanaconda/installation.py", line 366, in doInstall
installation_queue.start()
File "/usr/lib64/python3.6/threading.py", line 864, in run
self._target(*self._args, **self._kwargs)
File "/usr/lib64/python3.6/site-packages/pyanaconda/threading.py", line 252, in run
threading.Thread.run(self)
gi.overrides.BlockDev.LVMError: Failed to call the 'PvCreate' method on the '/com/redhat/lvmdbus1/Manager' 
object: GDBus.Error:org.freedesktop.DBus.Python.dbus.exceptions.DBusException: 
('com.redhat.lvmdbus1.Manager', 'PV /dev/md/126 Already exists!')
edit retag flag offensive close merge delete

Comments

What is your question? What were you trying to accomplish? What did you already try? The last line clearly says whats wrong.

Aeyoun gravatar imageAeyoun ( 2019-02-15 06:27:16 -0500 )edit

Sorry, it was my first question, it my mistake. My question is, "Why PvCreate does not work?". This does not always happen. But sometimes it happens and causes problems. I always tried to install in same environment. But I do not know why it was occured in sometimes. At first I thought PvScan was causing problems, but still does not work even adding workaround. So now I am looking for PvCreate issues, but I can not see the logs registered in REDHAT.

bugzilla = 1589871, 1586148, 1588697 Redhat = https://access.redhat.com/solutions/2...

ham1084 gravatar imageham1084 ( 2019-02-18 00:02:15 -0500 )edit