Ask Your Question
0

Windows MS fonts in Fedora 29

asked 2019-02-15 18:23:18 -0500

alfC gravatar image

updated 2019-02-19 22:22:36 -0500

After installing msttf core fonts from fedy (Microsoft Core Fonts), some emails in the Firefox browser look like this:

font

As you can see, I have activated Font Smoothing (for example from Gnome Tweaks) but this Microsoft font (Calibri?) looks really bad (except the liguatures, like ti).

Is there a way to activate a more agressive font smoothing for this set of TrueType Fonts?


EDIT: I use these settings:

tweakfonts

edit retag flag offensive close merge delete

Comments

Are you sure it's specific to Windows fonts? Have you checked settings in Appearance -> Fonts -> Details ? Make sure DPI, subpixel smoothing, hinting, subpixel order, etc are appropriate for your display.

fasulia gravatar imagefasulia ( 2019-02-17 21:24:54 -0500 )edit

@fasulia, yes, I see this only after installing MS fonts, and from friends emailing me from MS Office programs. Before installing MS fonts I don't see this problem, Fedora substitutes the MS font by its own replacement and it looks good. Yes, I am using all these features, see my edit.

alfC gravatar imagealfC ( 2019-02-19 17:41:20 -0500 )edit

I also can confirm that the problem is particularly bad with the Calibri font. (the one shown). I see the same problem in LibreOffice, despite of having font-smoothing anti-aliasing turned on.

alfC gravatar imagealfC ( 2019-02-19 18:20:32 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2019-02-19 18:43:13 -0500

alfC gravatar image

updated 2019-02-25 10:17:31 -0500

EDIT: I solved this using the following method:

https://ask.fedoraproject.org/en/ques...


Out of desperation, I followed blindly these instructions https://github.com/silenc3r/fedora-be... and the font rendering in now ok in Firefox. I don't know if this solved the problem or simply substituted MS fonts by close equivalents. Besides, the problem is not completely gone because LibreOffice still shows a bad rendering of small Calibri fonts, which unfortunately are nowadays used in almost all documents.

This also had the side effect that many fonts now look to narrow to my taste.

On the left Firefox, on the right LibreOffice:

current


I think I know what happened, usually I install Fedora and immediately I install Fedy, install "MS Fonts" Tweajs and activate the "Better Font Rendering" Tweak. This time the Fedy "Better Font Rendering" failed to execute because of some problem with Python code.

edit flag offensive delete link more
0

answered 2019-02-17 14:28:34 -0500

humourman gravatar image

Hi !

Personally i use this website to install Microsoft fonts and I never had any issues.
http://mscorefonts2.sourceforge.net/
if not you can try to enable the "use anti-aliasing".
I don't know if you have it in system settings as I use Fedora KDE.

edit flag offensive delete link more

Comments

It is the same package basically, the problem is that for some reason Fedora does the font smoothing only when the size of the font is above a certain (high) threshold, such as 18pt (for MS fonts). See my edit.

alfC gravatar imagealfC ( 2019-02-19 17:42:21 -0500 )edit
alfC gravatar imagealfC ( 2019-02-22 18:08:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-02-15 18:23:18 -0500

Seen: 879 times

Last updated: Feb 25