Ask Your Question
1

package collision (x86_64 / i686) on dnf update

asked 2019-03-09 08:15:19 -0500

pueffl gravatar image

updated 2019-03-09 09:02:44 -0500

hhlp gravatar image

Since a week or so, I am no longer able to update my system (Fedora 29) because of colliding packages. The output is as follows (sorry, German text, but I think everyone should be able :

Datei /usr/share/doc/gdk-pixbuf2/NEWS aus der Installation von gdk-pixbuf2-2.38.1-1.fc29.i686 kollidiert mit der Datei aus dem Paket gdk-pixbuf2-2.38.0-6.fc29.x86_64
  Datei /usr/share/locale/be/LC_MESSAGES/gdk-pixbuf.mo aus der Installation von gdk-pixbuf2-2.38.1-1.fc29.i686 kollidiert mit der Datei aus dem Paket gdk-pixbuf2-2.38.0-6.fc29.x86_64
...

The problem seems to be to me that dnf tries to install the same package for 2 different architectures (x86_64 and i686). Any ideas how to fix this and why this happens?

Thanks in advance,

Wolfgang

edit retag flag offensive close merge delete

Comments

For future reference, if you ever want to run a command and turn off localization (translation to your system language), just run it with LANG=C ahead of the command, in this case LANG=C sudo dnf update

florian gravatar imageflorian ( 2019-03-09 09:07:02 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2019-03-09 09:41:37 -0500

villykruse gravatar image

updated 2019-03-10 01:11:48 -0500

Running dnf update gdk-pixbuf2.x86_64 gdk-pixbuf2.i686 should have updated to

gdk-pixbuf2-2.38.1-1.fc29.x86_64
gdk-pixbuf2-2.38.1-1.fc29.i686

If that does not install wouldout conflicts you found an error that should be reported via bugzilla. Of course, if you do not need the gdk-pixbuf2.i686 by all means remove it. But then again, I have to assume it was installed originally for a valid reason.

The real reason that dnf did not chose to upgrade to gdk-pixbuf2-2.38.1-1.fc29.x86_64 might have been given in some message that was not shown to us.

edit flag offensive delete link more
0

answered 2019-03-09 09:16:59 -0500

XtyM gravatar image

updated 2019-03-09 10:45:50 -0500

Have you think about remove the package (i686) and try after update? Something like:

sudo dnf remove gdk-pixbuf2-2.38.0-6.fc29.i686 
sudo dnf autoremove && sudo dnf clean all 
sudo dnf update --refresh

And after you can try install the package again if you need it? sudo dnf install gdk-pixbuf2-2.38.1-1.fc29.i686

In the other hand you also could try update via comando --allowerasing like : sudo dnf upgrade --allowerasing

Maybe someone with more experience can help you. It is what i could imagine out what i could try.

edit flag offensive delete link more

Comments

dnf autoremove is a very dangerous command. Unless you read and understand what it is doing, I would suggest not to use it.

florian gravatar imageflorian ( 2019-03-09 21:32:38 -0500 )edit
0

answered 2019-03-09 09:08:46 -0500

florian gravatar image

Assuming your system is a x86_64 (64bits) system, you can simply remove the confliciting .i686 package and then run the update process.

sudo dnf remove gdk-pixbuf2-2.38.1-1.fc29.i686
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-03-09 08:15:19 -0500

Seen: 59 times

Last updated: Mar 10