Ask Your Question
1

Installing grub after instalation of Fedora29 (SOLVED)

asked 2019-03-11 15:51:18 -0500

XtyM gravatar image

updated 2019-03-12 23:55:37 -0500

Hi,

I have 2 disk :

[jorge@fedora-29 ~]$ lsblk -f
NAME   FSTYPE    LABEL         UUID                                   MOUNTPOINT
sda                                                                   
├─sda1 ntfs      Återställning 1E9C94E29C94B62D                       
├─sda2 vfat                    5895-9BE4                              
├─sda3                                                                
└─sda4 ntfs                    2EDE9941DE99026F



sdb                                                                   
├─sdb1 vfat                    6946-F562                              /boot/efi
├─sdb2 ext4                    d8c4fd17-394f-475e-949b-d3c9f85623e9   /boot
└─sdb3 LVM2_memb               76h2QS-WX92-ONE3-8hgX-7G0Z-uXsQ-8BPN3R 
  ├─fedora-root
  │    ext4                    5f49e753-440a-4731-b16d-515f578f9969   /
  ├─fedora-swap
  │    swap                    f4a6d796-e1d4-4ed8-a674-2af9ac5aa2b6   [SWAP]
  └─fedora-home
       ext4                    9ce27f15-5033-4498-a8a0-952ad4355678   /home

I have windows (in sda with its efi loader into sda2) before I installed fedora i disconected disk sda becouse i didn't want have grub menu if not that i would select the OS from Bios. The problem is that every time I start an operating system, new repeated entries are generated that refer to the 2 hard disks. Which I have to manually delete because they become excessive. What would be the best solution to not have the problem that these repeated entries are generated automatically (I would like to be able to select the OS from the Bios but if there is no alternative I would have to install the grub inside dev / sdb1?) Which would be the procedure guide for do what?)

Thank you very much for any contribution.

Like this:

[jorge@fedora-29 ~]$ efibootmgr
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,005C,0062,0063,0066,0067,0060,005E,005F,0061,0064,0065,0068
Boot0000* Fedora
Boot005C* UEFI: KINGSTON SA400S37240G
Boot005D* Samsung SSD 860 EVO 250GB
Boot005E* CD/DVD Drive 
Boot005F* UEFI: Built-in EFI Shell 
Boot0060* Hard Drive 
Boot0061  UEFI: KINGSTON SA400S37240G
Boot0062* UEFI: Samsung SSD 860 EVO 250GB
Boot0063* UEFI: KINGSTON SA400S37240G
Boot0064  UEFI: Samsung SSD 860 EVO 250GB
Boot0065  UEFI: KINGSTON SA400S37240G
Boot0066* UEFI: Samsung SSD 860 EVO 250GB
Boot0067* Windows Boot Manager
Boot0068  UEFI OS
edit retag flag offensive close merge delete

Comments

Sounds like a bug in the UEFI implementation. Can you check if there are any updates available?

villykruse gravatar imagevillykruse ( 2019-03-12 01:11:42 -0500 )edit

I did update all and reinstall grub2 ..but still every entry is going more and more entries

XtyM gravatar imageXtyM ( 2019-03-12 09:12:04 -0500 )edit

How about the UEFI firmware from the manufacturer of your computer?

villykruse gravatar imagevillykruse ( 2019-03-12 09:43:35 -0500 )edit

Uefi firmware is ok i had other distro before and the problem did not happen

XtyM gravatar imageXtyM ( 2019-03-12 10:10:09 -0500 )edit

Enter your bios . Get to EFI or Secure Boot Options . You will hopefully find there a menu where you have to select the fedora efi bootloader to a safe bootloader to use. Mark it as safe and save you bios settings.

ACER has made us runing in circles for hours before we found this bios option.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-03-12 10:27:55 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-03-12 23:52:50 -0500

XtyM gravatar image

updated 2019-03-13 12:02:21 -0500

Hi

I had disable secure boot by default the only thing into boot options that i had not modified was change the option boot Legacy+UEFI to only UEFI this did in the next restart regenerate grub changing grubshimx64 for grubx64 and it solve the issue stopping of entries autogeneration

Edit:

@Rdtcustomercate was right I had to load the authorized signatures for fedora in the Bios on the Bios Board MSI click 4 is hidden in the windows 8 option whose entry is disabled by default. When the active one appears a new option (that was invisible) to select signatures to be imported during the loading of the Bios. As he assured this was the problem which is finally solved thanks to him.

Thank you.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-11 15:51:18 -0500

Seen: 128 times

Last updated: Mar 13