Ask Your Question
0

[RESOLVED] Firefox won't playback video in Twitter or audio in Spotify

asked 2019-03-13 09:57:42 -0500

spaceman gravatar image

updated 2019-03-14 08:38:49 -0500

Firefox Quantum 65.0.2 (64-bit). Fresh build of Fedora 29, previous install didn't work in the same way: "We cannot play the video in this browser. Please try a different web browser." - Twitter. CLicking play in Spotify simply does nothing.

I have removed cookies, cleared cache, deleted profile, removed and reinstall Firefox.

Pulseaudio is installed and working. No plugin is signaled as missing. No addons or themes are installed. Behaviour is the same in Safe Mode. Both Twitter and Spotify are added as exceptions to "Block pop-up windows" settings. Hosts file does not include ad.doubleclick.net.

Video and audio is fine on other websites, e.g. Youtube. This does not occur on Debian based distros: Debian 9, antiX Linux 17 'Heather Heyer', Xubuntu 18:10...also happens with Chromium, which suggests to me this is a Fedora issue.

edit retag flag offensive close merge delete

Comments

Check your codec support with this testpage.

It should show support of all of these

HTMLVideoElement
H.264
WebM VP8
Media Source Extensions
MSE & H.264
MSE & WebM VP9
villykruse gravatar imagevillykruse ( 2019-03-13 15:13:07 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-13 11:34:13 -0500

aeperezt gravatar image

You need to install video codes from http://rpmfusion.org install free nonfree version then install all codecs. Fedora do not include nonfree video codecs, so you must get them from rpmfusion.org, after install they will work

Good Luck

edit flag offensive delete link more

Comments

Knowing I was two codecs short was an excellent start this answer told me where to get them. I used

sudo dnf install https://download1.rpmfusion.org/{free/fedora/rpmfusion-free,nonfree/fedora/rpmfusion-nonfree}-release-$(rpm -E %fedora).noarch.rpm

...to install the repos I required, then the packages I need to install H.264 and MSE & H.264 were:

sudo dnf install compat-ffmpeg28 ffmpeg-libs

Thank you villykruse and aeperezt.

spaceman gravatar imagespaceman ( 2019-03-14 08:38:02 -0500 )edit

And here's the magic string :P sudo dnf install gstreamer-{ffmpeg,plugins-{good,ugly,bad{,-free,-nonfree}}} gstreamer1-{plugin-mpg123,libav,vaapi,plugins-{base,bad-free{,world,-extras},good{,-extras},ugly}}

vmercuri gravatar imagevmercuri ( 2019-03-14 09:00:16 -0500 )edit

Thank you all, by bad/good luck, I happened to run into the same question/problem [and stumbled upon the [this] top-post addressing my problem, must be my lucky day]. The post by spaceman (planet earth is blue, there is nothing I can do) did the trick, thanks mate, you're out there!

degski gravatar imagedegski ( 2019-03-14 09:47:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-03-13 09:57:42 -0500

Seen: 81 times

Last updated: Mar 14