Ask Your Question
0

Upgrade minor version of php

asked 2019-03-14 03:24:01 -0500

leggy gravatar image

this is strictly connected with my other question.

I'm in a situation where I have php 7.2 provided by php72-2.0-1.fc29.remi.x86_64 package and all php extensions provided by php-[EXTENSION_NAME]-7.2.15-1.fc29.x86_64 packages.

problem is that I want to install php-oci8 extension but, for some reason (probably due to Murphy's law), it seems to be not available from remi's repository for the 7.2.15-1.fc29 version.

for what I can see, in remi's repository there are available in the form php-oci8-7.2.16-2.fc29.remi.x86_64 or php-oci8-7.2.15-1.fc28.remi.x86_64.

So I thought that the easiest way would be to update all php extensions to 7.2.16 version but, how to do it?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-03-14 04:15:08 -0500

remi gravatar image

updated 2019-03-14 04:16:04 -0500

Better place to ask for 3rd party repository, is on dedicated forum https://forum.remirepo.net/

Indeed, I only keep 2 versions online (so 7.2.16 and 7.2.17 for now), older versions are still available in an archive directory, but not a repository.

So I thought that the easiest way would be to update all php extensions to 7.2.16 version but, how to do it?

dnf update

Of course, with the repository enabled. See the Wizard instructions

edit flag offensive delete link more

Comments

thank you remi. I apologize for my naive question

leggy gravatar imageleggy ( 2019-03-18 04:51:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-14 03:24:01 -0500

Seen: 17 times

Last updated: Mar 14