Ask Your Question
1

Super User (su) not working

asked 2013-02-24 17:24:10 -0500

STR gravatar image

updated 2014-09-28 18:21:03 -0500

mether gravatar image

I have installed Fedora 18 in VMware. I can't log in to super user (su) mode because it claims the root password is incorrect (it isn't). I have tried installing F18 twice, each time setting the root password at the start of installation.

edit retag flag offensive close merge delete

Comments

Thanks, but that solution will not work for me. I am not in the sudoers file yet and I think I need su to change that. It is a catch22.

STR gravatar imageSTR ( 2013-02-24 18:07:34 -0500 )edit

When you installed your Fedora it asks for a root password. Didn't you choose it ?

lnxslck gravatar imagelnxslck ( 2013-02-24 18:16:18 -0500 )edit

Yes. I have reinstalled it twice now making sure I typed in the root password each time.

STR gravatar imageSTR ( 2013-02-24 18:27:38 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-02-24 17:35:53 -0500

You need to login with your normal user and then do:

sudo su -

Then if you want you can change the password of root:

passwd
edit flag offensive delete link more
1

answered 2013-02-24 18:36:12 -0500

ryanlerch gravatar image

Not exactly sure how you are not setting the root password.

In the "second hub" of anaconda, there should be an Root Password option there where you create the root password for your installation:

image description

Note that even if you don't set it there, you should also be able to set up the root password during firstboot (the screens that show up after you reboot after install)

Also, in firstboot, when you create your normal user, you should be able to "Set as Administrator" to give it sudo access.

Even after trying all these things, and still can't get root access, you can always try to reset the root password after installation using the single user mode technique:

https://fedoraproject.org/wiki/Howtoresetaroot_password

edit flag offensive delete link more

Comments

Thanks for your excellent post. I did set the root password previously exactly where you indicate and had confirmation of it. But su password is not working. However, I have now went through the install a 3rd time. But this time I did see the option to set myself as admin during the initial boot. Su is not still not working but now I can get to the # prompt using "sudo su -" as suggested by lnxslck. Thanks to you both.

STR gravatar imageSTR ( 2013-02-24 19:14:19 -0500 )edit

now you could also try, (after doing the "sudo su -" ), trying a "passwd" command to reset the root password. Then you may be able to just do "su -" in the future. Also, if this answered your question, would you be able to press the "tick" up near the upvote / downvote for the answer to mark it as "correct"? cheers!

ryanlerch gravatar imageryanlerch ( 2013-02-24 20:00:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-24 17:24:10 -0500

Seen: 15,107 times

Last updated: Feb 24 '13