Ask Your Question
0

The Disk contains an unclean file system in Fedora

asked 2013-03-08 14:40:08 -0500

hhlp gravatar image

updated 2014-05-11 13:43:57 -0500

mether gravatar image

Have you ever got this error trying to mount a NTFS partition in LINUX after using in a Windows Machine:

The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount `/dev/xxxx`: Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
(udisks-error-quark, 0)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2013-03-08 14:45:30 -0500

hhlp gravatar image

updated 2013-03-08 14:56:36 -0500

The solution is so simple :

here is where NTFS-3G project come to help us:

On computers which can be dual-booted into Windows or Linux, Windows has to be fully shut down before booting into Linux, otherwise the NTFS file systems on internal disks may be left in an inconsistent state and changes made by Linux may be ignored by Windows.

So, Windows may not be left in hibernation when starting Linux, in order to avoid inconsistencies. Moreover, the fast restart feature available on recent Windows systems has to be disabled. This can be achieved by issuing as an Administrator the Windows command which disables both hibernation and fast restarting.

Double-booting Linux and Windows 8

When Windows 8 is restarted using its fast restarting feature, part of the metadata of all mounted partitions are restored to the state they were at the previous closing down. As a consequence, changes made on Linux may be lost. This can happen on any partition of an internal disk when leaving Windows 8 by selecting Shut down or Hibernate. Leaving Windows 8 by selecting Restart is apparently safe.

To avoid any loss of data, be sure the fast restarting of Windows 8 is disabled. This can be achieved by issuing as an administrator the command :

or follow this step :

Settings 
 > control panel
 > system security
 > administrative tools
 > system configuration
 > tools
 > command prompt and launch it and type this :
powercfg /h off

You can check the current settings on :

Control Panel 
    > Hardware and Sound 
    > Power Options 
    > System Setting 
    > Choose what the power buttons do

The box "Turn on fast startup" should either be disabled or missing.

Source : here

edit flag offensive delete link more

Comments

didnt work for me. i tried "ntfs-3g /dev/sda1 /mnt/windows" but no go. i tried the gnome disk tool to automount at start up but no go. i am using windows 8 btw

MrAmbiG gravatar imageMrAmbiG ( 2014-07-07 01:33:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-08 14:40:08 -0500

Seen: 9,531 times

Last updated: Feb 11 '14