Compose key mapping does not work in Fedora 18?

asked 2013-03-25 13:25:17 -0500

BRPocock gravatar image

updated 2014-09-05 10:50:25 -0500

mether gravatar image

After upgrading to Fedora 18, my Compose key seems to be non-functional.

I have the keyboard layout set to the default English/US, and in System Settings → Keyboard → Shortcuts → Compose Key = Caps Lock.

The Caps Lock key seems now to be totally dead; it neither toggles capitalization, nor does it work as a Compose key.

Strangely, xmodmap shows this line:

        66         0xff20 (Multi_key)      0xff20 (Multi_key)      0xff20 (Multi_key)      0xff20 (Multi_key)

If I change Compose Key = Disabled, that changes to

        66         0xffe5 (Caps_Lock)      0x0000 (NoSymbol)       0xffe5 (Caps_Lock)

... and that does work; so keysym=66 seems to be the right place, and Multi_Key (Compose) is being bound to it.

Do I perhaps have to choose a Compose key table to load? (locale=en_US.UTF-8 and /usr/share/X11/locale/en_US.UTF-8/Compose exists with more-or-less the contents I would expect to see)

The same effect occurs on both built-in keyboard (laptop) or USB keyboard.

I have also attempted to use the Tweak tool to turn off Caps Lock, but that seems to have no effect.

Am I just "doing it wrong?"

edit retag flag offensive close merge delete

Comments

I've since upgraded to Fedora 19 and this bug seems to have vanished. Emacs, on the other hand, took some “convincing” to accept the Compose key.

BRPocock gravatar imageBRPocock ( 2013-09-04 13:48:27 -0500 )edit