Ask Your Question
0

Fedup lands at grub prompt... [closed]

asked 2013-05-20 15:31:47 -0500

BRPocock gravatar image

updated 2014-09-30 23:10:27 -0500

mether gravatar image

After running FedUp (from 17 to 18), my machine now drops directly to a grub> prompt.

Fortunately, I can key in the sequence of linux vmlinuz... // initrd initramfs-... and boot to load the system, and this is a "desktop" machine that doesn't usually get rebooted , but it's still quite annoying.

I've tried doing a yum reinstall of grub2,grubby,kernel, and anything else that I thought might "do it," but to no avail, and without any obvious error messages being logged.

This is an x86_64 machine with nVidia graphics and BIOS boot method, if that helps.

How would I go about forcing Grub to load its menu configuration?

Relevant(?) packages: grub2-2.00-15, kernel-3.8.6-203, kernel-3.8.7-201, kernel-3.8.8-202, grubby-8.22-1

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by BRPocock
close date 2015-08-06 13:15:25.377610

Comments

Closing this, due to ancient age.

BRPocock gravatar imageBRPocock ( 2015-08-06 13:15:06 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-05-20 15:38:22 -0500

mether gravatar image

updated 2013-05-20 15:39:05 -0500

Apparently, grub2-install is what you are looking. I haven't verified this however.

edit flag offensive delete link more

Comments

I'm a bit cautious about that, since it says it will run grub-setup to re-write the boot sector, and this seems to be more like the config files being corrupt/absent than the boot sector being corrupted; however, I'll try re-running it this evening (when I'll have physical access to the machine) and see if it does help.

BRPocock gravatar imageBRPocock ( 2013-05-20 15:42:01 -0500 )edit

Question Tools

Stats

Asked: 2013-05-20 15:31:47 -0500

Seen: 135 times

Last updated: Aug 26 '13