Ask Your Question
2

Cannot adjust brightness?

asked 2013-06-02 06:24:26 -0500

ellixt gravatar image

updated 2013-06-03 06:48:41 -0500

I cannot change the brightness on my system, whether that be, via the brightness menu in system settings, or using the FN keys.

The animation shows, but the brightness does not change. I had the same issue on Ubuntu, which was solved by making changes to the /etc/default/grub file.

However, I do not know how to do this in Fedora, as I've only just made the switch.

edit retag flag offensive close merge delete

Comments

15 Answers

Sort by ยป oldest newest most voted
3

answered 2013-06-03 03:16:10 -0500

jamielinux gravatar image

updated 2013-06-03 03:18:30 -0500

https://jamielinux.com/articles/2013/06/cannot-adjust-screen-brightness-on-fedora/

There is one thing to try that usually fixes this. Open /etc/default/grub in your favourite editor and find the line that starts with GRUB_CMDLINE_LINUX. Append acpi_backlight=vendor to this line.

edit flag offensive delete link more

Comments

Your solution is partially correct, as it may not work if the system has more than 1 GPU (ex: nvidia + intel graphics). The solution would be to use either of acpi_backlight=video, acpi_backlight=vendoracpi_backlight=native or acpi_backlight=none

source: link

newLineCharacter gravatar imagenewLineCharacter ( 2016-09-11 19:40:16 -0500 )edit

yeah, this solution works.

kumargaurav gravatar imagekumargaurav ( 2016-11-05 12:28:49 -0500 )edit

could use this to save the grub configurations,

sudo grub2-mkconfig -o /boot/grub2/grub.cfg
kumargaurav gravatar imagekumargaurav ( 2016-11-07 11:34:36 -0500 )edit

none of these opyions worked for me F24 Asus UX302L I did have this working when I was on Arch.

ReeseZee gravatar imageReeseZee ( 2016-12-08 10:50:51 -0500 )edit

the grub file mentioned is showing up as read only on my system. What should i do?

blastoise gravatar imageblastoise ( 2017-07-04 11:28:12 -0500 )edit
0

answered 2013-07-05 22:05:45 -0500

shark gravatar image

updated 2014-01-31 06:06:07 -0500

hi

i had the same problem with acer aspire too. simply go to /etc/default/grub.cfg as root in the GRUB_CMDLINE_LINUX= (............) paste these lines in the end , within the inverted commas

quiet splash pcie_aspm=force acpi_osi=Linux acpi_backlight=vendor

and run grub2-mkconfig -o /boot/grub2/grub.cfg

changes take place at reboot

edit flag offensive delete link more

Comments

After a long struggle ,i tried this and worked well Thanks a lot

Rejith Paul gravatar imageRejith Paul ( 2014-02-26 00:43:20 -0500 )edit

I had the same problem with my acer aspire 4830. Brightness adjustment used to work out of the box with Fedora 19. The other day I just noticed it stopped working after I had done some changes. This fixed it again! Thank you!

cptnabla gravatar imagecptnabla ( 2014-03-21 03:24:21 -0500 )edit

This work for me on F28 Gnome desktop/Acer Aspire 4732. Thanks!

raul8salazar gravatar imageraul8salazar ( 2018-07-09 18:15:15 -0500 )edit
0

answered 2014-02-01 14:39:50 -0500

quantenselbstmord gravatar image

all answer are ok, but if you use LXDE this solution isn't work ( i don't know , but not work)

try with xblacklight

install xblacklight

dnf -y install xblacklight

set brightness in porcent

xbacklight -set X%

set brightness for +

xbacklight -inc 20

set brightness for -

xbacklight -dec 20

good luck !

edit flag offensive delete link more
0

answered 2017-05-08 06:48:08 -0500

zalasu gravatar image

For Lenovo T61 users following steps are useful: Install xbacklight, then to dim the screen: xbacklight -set 40 (replace 40 with the level of brightness that suits you). Hope this helps. You can also check Lenovo Thinkpad T61 Manual for detailed help.

edit flag offensive delete link more
0

answered 2015-10-30 21:35:47 -0500

updated 2015-11-01 13:41:20 -0500

On my ASUS UX303LB, I couldn't get the Fn+F5 and Fn+F6 keys to work with any of the kernel parameters suggested. The keys don't even generate events if I check with xev.

As a work-around, I added the file /etc/sudoers.d/backlight with:

ALL ALL = (ALL) NOPASSWD: /usr/bin/tee /sys/class/backlight/intel_backlight/brightness

and created the following shortcuts in keyboard settings:

  • Name: Brightness +
    Command: bash -c 'sudo tee /sys/class/backlight/intel_backlight/brightness <<<$(( $(cat /sys/class/backlight/intel_backlight/brightness) + 15 ))'
    Accelerator: Super+F6
  • Name: Brightness -
    Command: bash -c 'sudo tee /sys/class/backlight/intel_backlight/brightness <<<$(( $(cat /sys/class/backlight/intel_backlight/brightness) - 15 ))'
    Accelerator: Super+F5

I now can use F5 and F6 together with the Windows key to adjust brightness.

edit flag offensive delete link more

Comments

This did not work on Fedora24 on ASUS UX302L

ReeseZee gravatar imageReeseZee ( 2016-12-08 10:50:07 -0500 )edit
0

answered 2016-06-19 15:51:29 -0500

ayeung gravatar image

updated 2016-06-19 19:44:44 -0500

None of these answers (or the other answers I found online) worked for me. Instead I was able to fix this issue on my Lenovo T430 running Fedora 23 XFCE with this (somewhat ugly) workaround.

Make sure xbacklight is installed (sudo dnf install xbacklight) and ensure that xbacklight actually changes your brightness.

Then manually map the key commands (Settings Manager -> Keyboard -> Application Shortcuts) for brightness to the xbacklight command. For example, I mapped "/usr/bin/xbacklight -dec 10" to "Fn+F8" and that allows the key combination to decrease brightness as it was intended to do.

Then reboot and the brightness keys should work!

I hope that helps! :)

edit flag offensive delete link more

Comments

to get xbacklight to worok on ASUS UX302L i915 haswell F24 I had to remove "nomodeset" from boot params. Additionally the "Fn" does not register in xev so I mapped "super" to the F5 & F6 keys for the xbacklight shortcut

ReeseZee gravatar imageReeseZee ( 2016-12-08 11:40:37 -0500 )edit
0

answered 2014-03-13 09:31:41 -0500

Tinker gravatar image

Via the link above note the "update" at the bottom of the piece for anyone Linux 3.13 above. The original fix would hang my system at boot. The new command video.use_native_backlight=1 worked first time and I can now dim my screen. Happy days :-)

edit flag offensive delete link more
0

answered 2014-02-08 15:33:08 -0500

alam gravatar image

For the records, i had also the same issue and i've created long time ago a quick bash script. It is NOT complete from programming point of view. Please feel free to make it better or just use it (it requires root privileges).

#!/bin/bash 

# Date: 01.07.12
# Author: alampropoul@gmail.com
# Acer Aspire 5742G Brightness Emergency Correction
# Version : 1.0

currentvalue=`cat /sys/class/backlight/intel_backlight/brightness`
CHOICE='Please enter your choice'
LIST="Brighter Darker END"
select CHOICE in $LIST
do
if [ $CHOICE = "Brighter" ] &> /dev/null
then
currentvalue=`cat /sys/class/backlight/intel_backlight/brightness`
echo $currentvalue
let "currentvalue+=100"
echo $currentvalue > /sys/class/backlight/intel_backlight/brightness
elif [ $CHOICE = "Darker" ] && [ "$currentvalue" -gt 101 ]
then
currentvalue=`cat /sys/class/backlight/intel_backlight/brightness`
echo $currentvalue
echo $currentvalue
let "currentvalue-=100"
echo $currentvalue > /sys/class/backlight/intel_backlight/brightness
elif [ $CHOICE = "END" ] &> /dev/null
then
exit 0
fi
done
#END
#[1;5D
edit flag offensive delete link more
0

answered 2013-06-02 16:26:01 -0500

tz gravatar image

I don't know why it doesn't with mine either, to echo an answer from elsewhere about manually changing it:

there is /sys/class/backlight which will have directories for backlight hardware. In them will be a "brightness" and "max_brightness" entries.

echo (whatever was in max_brightness) >brightness will go to the top, but for example if max is 10, echoing 5 > brightness will be half brightness, if max is 250, echoing 125 will be half brightness.

edit flag offensive delete link more
0

answered 2017-03-04 16:22:40 -0500

bargem gravatar image

This worked for me running Fedora 25 on ThinkPad X200

  1. Install xbacklight

    dnf install xbacklight
  2. Open grub file for edit

    gedit /etc/default/grub
  3. Append acpi_backlight=vendor to GRUB_CMDLINE_LINUX=

    EXAMPLE:

    GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root nomodeset rhgb quiet"
    GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root nomodeset rhgb quiet acpi_backlight=vendor"
  4. SAVE

  5. Rebuild Grub:

    sudo grub2-mkconfig -o /boot/grub2/grub.cfg
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-06-02 06:24:26 -0500

Seen: 55,017 times

Last updated: Mar 04 '17