Ask Your Question
1

Unable to mount NTFS drive [closed]

asked 2013-06-12 15:40:32 -0500

Hello guys, I wanna access my windows 8 document files (pictures etc...) but here's the problem i can't even mount the drive i've tried some different ways but with no result.

here's the error:

Unable to access “262 GB Volume”

Error mounting /dev/sda2 at /run/media/wifu/BED8A8B0D8A867FB: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda2" "/run/media/wifu/BED8A8B0D8A867FB"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0). Metadata kept in Windows cache, refused to mount. Failed to mount '/dev/sda2': Operation not permitted The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by NickTux
close date 2014-07-07 04:46:15.885193

3 Answers

Sort by » oldest newest most voted
2

answered 2013-06-12 16:13:26 -0500

sideburns gravatar image

The error message not only tells you what's wrong, it tells you exactly how to fix it: restart Windows, run scandisk and let it fix whatever errors there are in the file system. Then, when you restart Fedora, the drive should mount properly.

edit flag offensive delete link more

Comments

Actually, there is no need to run scandisk. Just boot Windows and restart. Then boot Fedora. Don't do hibernate. If you are using Windows 8, don't use 'fast restarting'. If in doubt, shutdown windows completely and then boot Fedora.

hedayat gravatar imagehedayat ( 2013-06-13 02:32:41 -0500 )edit

I got it that the windows is now hibernated and thats why i can't access the drive (its written bellow the error) but the problem is in that i can't restart the computer ... i can't make it down...

Shavi Meraba gravatar imageShavi Meraba ( 2013-06-13 07:49:26 -0500 )edit

As suggested at the end of the error message, you can mount the partition read-only if you only want to access your files. You can force a read-write mount, however it is likely that your filesystem will be damaged. Try: mount -o ro /dev/sda2 /mnt/ and see if it mounts without any errors. Then, you can access files in /mnt

hedayat gravatar imagehedayat ( 2013-06-13 15:05:58 -0500 )edit

Thanks for the help. My Windows became unbootable, but this command helped

Easa gravatar imageEasa ( 2014-02-23 01:47:51 -0500 )edit

mount -o ro /dev/sda2 /mnt/

this worked. thanks

yashp90 gravatar imageyashp90 ( 2014-02-28 17:14:00 -0500 )edit
0

answered 2014-07-07 01:48:17 -0500

MrAmbiG gravatar image

Did a ntfsfix /dev/sdb1 then just opened the drive and it worked fine. :)

edit flag offensive delete link more

Comments

ntfsfix just removes the dirty flag manually - it doesn't actually put the filesystem in a clean state. This isn't a safe procedure.

randomuser gravatar imagerandomuser ( 2014-07-07 10:52:14 -0500 )edit

ntfsfix /dev/sda5 worked for me.

roy_soumya gravatar imageroy_soumya ( 2016-02-04 13:27:37 -0500 )edit

I actually need to do ntfsfix /dev/sda2 (depending upon my sda which we can check through sudo fdisk -l or see in the drived itself) and then do the mount using command mount -o ro /dev/sda2 /mnt/ for each of the sda's I wanted to mount and then restart the fedora using reboot.

Animesh Singh gravatar imageAnimesh Singh ( 2017-03-24 04:20:42 -0500 )edit
0

answered 2013-09-15 01:19:29 -0500

imdad gravatar image

i got the same error. I mounted the drive as it says, nothing happened. I am using windows 8, i did shutdown windows twice, and now i cant even see the drive in 'Files'.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-06-12 15:40:32 -0500

Seen: 18,298 times

Last updated: Jul 07 '14