Ask Your Question

Grub2 timeout too short

asked 2013-07-20 20:55:24 -0500

mq2132 gravatar image

updated 2013-07-22 05:18:01 -0500

FranciscoD_ gravatar image


This is my first time posting and I have a question that I know is going to sound very stupid.

I changed my grub timeout value to 0.5 seconds.

Now I do not have enough time to change to Fedora 19 and it automatically boots into Windows 7.

If anyone could help me I would really, really appreciate it.


edit retag flag offensive close merge delete


Keep shift pressed on boot. It should disable the count down. If that doesn't work, you're going to have to use the rescue mode from a Fedora dvd to re-modifiy your count down value as @hmaarrfk suggests.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-07-22 05:16:03 -0500 )edit

BTW, no question is stupid, I've done the same mistake you have before.

hmaarrfk gravatar imagehmaarrfk ( 2013-07-23 01:17:34 -0500 )edit

Thank you @hmaarrfk this forum has been extremely helpful as I tried to learn Fedora and Linux in general.

mq2132 gravatar imagemq2132 ( 2013-07-23 11:21:56 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-07-21 22:33:32 -0500

hmaarrfk gravatar image

updated 2013-07-23 01:20:54 -0500

Hi there,

I think the easiest way is to pop in your live dvd / usb and to change the timeout value from there.

Just make sure you are indeed changing the timeout value of your hard-disk installation and not simply the one that is saved on the usb/dvd.

------------------- Bad alternative solution below --------------- I really do not like to include this possible solution because I don't think you should open ext file systems in Windows. I don't trust the implementations and they may leave your disk corrupt.

You can try to follow these instructions

but I don't know what will happen if you have an LLVM system (if you don't know what that means, don't worry about it too much, wikipedia if your friend if you care to learn). No guarantees this will work

edit flag offensive delete link more


I tried the shift idea that @FranciscoD_ had and that did not seem to do the trick. I have tried to boot in using the usb but I do not know how to boot it up so I am able to change the timeout of the installed version. When I just booted it up and ran the commands to edit the grub.config, it was empty.

mq2132 gravatar imagemq2132 ( 2013-07-22 18:10:19 -0500 )edit

Hrm, pressing shift doesn't seem to work. How about just tapping any key on the keyboard? 0.5 seems short, but it should hopefully catch a key and stop the count down. Otherwise, you need to use the "rescue mode" from a DVD image as described here:

FranciscoD_ gravatar imageFranciscoD_ ( 2013-07-22 22:16:32 -0500 )edit

Once you boot up into a "live session", you can just see your hard drives on the left hand side of nautilus. You can then proceed to mounting the hard drive (should have a 1 second delay), and then you can open up the file to edit them.

you may need to open up the file as root, come back to this forum if you find that you are unable to save your file.

hmaarrfk gravatar imagehmaarrfk ( 2013-07-23 01:16:13 -0500 )edit

Okay I will try that. The first thing I did was to boot from the usb disk, however when I booted into the live version the two options I had were 1.) "Try Fedora" or 2.) "Install Fedora" it looked like this:

When I clicked "Try Fedora" it loaded up alright and then when I opened up Terminal and tried to run the su - commands that let me edit the grub.config file everything worked but the GRUB file was empty. Where exactly can I select my hard drive version? Thanks so much

mq2132 gravatar imagemq2132 ( 2013-07-23 11:17:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2013-07-20 20:55:24 -0500

Seen: 726 times

Last updated: Jul 23 '13