Ask Your Question
0

kmod-nvidia missing for kernel 3.10.10

asked 2013-09-04 13:56:08 -0600

Giulio A. gravatar image

updated 2013-09-05 05:22:05 -0600

FranciscoD_ gravatar image

Hi all,

I'm using F19 with nVidia card and I've just installed the new kernel 3.10.10 from stable fedora repo.

But the corresponding kmod-nvidia package, related to this kernel version, is totally missing. There is no kmod-nvidia package related to this kernel version, neither in stable repo, nor in testing or pending fedora 19 repos.

So, with this new kernel I can't use X at all, because the nvidia kernel module that should be located in

/lib/modules/3.10.10-200.fc19.x86_64/extra/nvidia/

is obviously missing.

Any suggestion?

edit retag flag offensive close merge delete

Comments

For yanglifu90,

thank you for your feedback.

I have rpmfusion nonfree repo installed and enabled. This is exactly the point. The kmod-nvidia package related to the new kernel 3.10.10 is currently missing.

For completeness, these are my actual fedora enabled repos:

Fedora 19 - x86_64
RPM Fusion for Fedora 19 - Free
RPM Fusion for Fedora 19 - Free - Updates
RPM Fusion for Fedora 19 - Nonfree
RPM Fusion for Fedora 19 - Nonfree - Updates
Fedora 19 - x86_64 - Updates
Giulio A. gravatar imageGiulio A. ( 2013-09-04 16:00:21 -0600 )edit

Thank you @sideburns, this solves the problem.

The only (little) thing I experiment in following your approach is that I had to reboot twice, in order to definitively solve. The first one the kernel nvidia module has been built, but not inserted. The second one, the kernel module has been correctly inserted.

@Sergei: I followed your suggestion when kernel 3.10.10 didn't have already the kmod-nvidia built and loaded.

Giulio A. gravatar imageGiulio A. ( 2013-09-05 03:10:06 -0600 )edit

@giulio-a please accept @sideburns answer as correct and reward him for his work :)

FranciscoD_ gravatar imageFranciscoD_ ( 2013-09-05 05:21:15 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2013-09-04 16:45:40 -0600

sideburns gravatar image

Your best bet in the long run is to install the akmod version. As root:

yum install akmod-nvidia

If you don't have the Development Tools installed:

yum install "Development Tools"

will get everything you need. Then, reboot into the latest kernel and akmod-nvidia will build the kmod for you. Just be patient, because it takes a little time. In the future, when you get a kernel update, if there's a kmod for it, you'll get it and akmod will do nothing; if it's not ready, yet, akmod will take care of it on the fly. (If you're concerned about boot times, akmod-nvidia takes maybe 30ms unless it has work to do.)

edit flag offensive delete link more
0

answered 2013-09-04 15:18:54 -0600

yanglifu90 gravatar image

Fodora does not provide proprietary drivers. Install rpmfusion nonfree repo here:

http://rpmfusion.org/Configuration

you will want nonfree 19, see http://rpmfusion.org/Howto/nVidia?highlight=%28CategoryHowto%29

edit flag offensive delete link more
0

answered 2013-09-05 01:01:17 -0600

Sergei gravatar image

updated 2013-09-05 01:03:04 -0600

My advice: to come back to kernel 3.10.9. For it you can find: kmod-nvidia-3.10.9-200.fc19 I hope the kmod 3.10.10 will appear soon

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-09-04 13:56:08 -0600

Seen: 2,372 times

Last updated: Sep 05 '13