Ask Your Question
1

How do I change the default video player from Dragon Player to VLC???

asked 2013-10-02 23:57:21 -0500

MrFrost gravatar image

I'm using F19.1 w/Plasma KDE and full updates on all packages. I'm trying to set the default video player to VLC, but for some reason it is not working. I've tried r-click open-w 'VLC' 'remember association' true. But when the next file I click it goes back to Dragon Player which is set as the default. I've also tried this in the file associations in the system settings and there when I remove DragonP from the preferences and add VLC, click ok it says updating associations and the process appears to finish, however VLC is not present in the preference list. Any help anyone can provide on changing the default video player to VLC is greatly appreciated. Also I might add that in Sys Sett > Default Apps there is not a multimedia tab to set preferences. But I'm sure you guys know this environment better than me, so that may be useless info. lol, but thanks again for any help.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2013-10-03 00:03:10 -0500

Brallan gravatar image

In KDE menu, go to System Settings, File Associations, find out "video". Select file type you would like to set VLC default player and in left panel move up VLC media player to first and apply. You must do the last instruction for each file type you want to set a default app.

edit flag offensive delete link more
0

answered 2013-10-03 16:33:36 -0500

sea gravatar image

updated 2013-10-03 16:34:10 -0500

How about just right-click the file in your favorite file-browser, and select File Properties and change the "Open With..." to the desired application?

edit flag offensive delete link more
-1

answered 2013-10-03 13:24:37 -0500

MrFrost gravatar image

Brallan thank you for the response, that didn't work. However I did figure it out, by accident. So I'm adding it here so to help others in the future. This is my first run at using Fedora and a full blown Linux environment for that matter. I hope everyone continues to contribute, so far I'm not impressed much, but its only been 2 days so we'll see.

Anyway, the problem derived from 'selinux'. Selinux is known to have some quirky bugs that respond with silent errors, what and why it had a problem with VLC IDK. So while setting up setting up my services and disabling 'selinux' upon restart I just happened to play a video after and saw that vlc was know in the default list, about 5x. It seems everytime I chose to make it a default it created a new entry. So with that said, I can't say for sure but with very good reason I do believe it selinux that was causing the issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-10-02 23:57:21 -0500

Seen: 6,412 times

Last updated: Oct 03 '13