Ask Your Question
0

Symbolic not allowed or link target not accesible

asked 2013-11-15 05:35:28 -0500

Bart Friederichs gravatar image

I am trying to setup a simple symbolic link into my home dir from /var/www/html, but I am gettings this error in my error log and the browser tells me it is forbidden:

[Fri Nov 15 12:24:53.709571 2013] [core:error] [pid 4971] [client 192.168.3.128:51372] AH00037: Symbolic link not allowed or link target not accessible: /var/www/html/devel

The devel is a softlink to /home/bf/Projects/P1234/web, and the entire path and all its subdirectories are world-executionable.

In my httpd.conf I have FollowSymLinks set.

<Directory "/var/www/html">
    Options Indexes FollowSymLinks MultiViews
    ...
</Directory>

I am using Fedora 19 (fresh install).

edit retag flag offensive close merge delete

Comments

Check /var/log/messages for SElinux errors - and run sealert - you will need to allow SElinux for apache to access home. As a side comment a nice way of checking permissions on the whole path: d=/home/bf/Projects/P1234/web; while test $d != '/'; do ls -ld $d; d=`dirname $d`; done - maybe someone will need that one day

marcindulak gravatar imagemarcindulak ( 2013-11-15 06:22:49 -0500 )edit

@marcindulak please post this as an answer, so I can accept it. It was exactly correct. The sealert program even gave me the way how to enable it by clicking "Details".

Bart Friederichs gravatar imageBart Friederichs ( 2013-11-15 06:32:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-11-15 08:03:06 -0500

marcindulak gravatar image

The problem turned out to be SELinux - see the comments above for details.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-11-15 05:35:28 -0500

Seen: 2,714 times

Last updated: Nov 15 '13