Ask Your Question
0

Yum is complaining about broken or duplicated libraries

asked 2013-11-15 14:08:24 -0600

highjo gravatar image

updated 2013-11-15 14:16:31 -0600

Hello, I might have done something I have no memory about but since 3 days, when I try to access google ,gmail, facebook from both google chrome and mozilla firefox. Seems certificates are rejected. But at the same time , I can use bing, ssl or not and other ssl protected sites.

I also tried to install a new application via yum. I don't know whether this are related issues but I had a lot of complains from yum. the issues are put in http://pastie.org/8483366

How can I fix all this mess?

Thanks

edit retag flag offensive close merge delete

Comments

1

You can always reinstall...

lnxslck gravatar imagelnxslck ( 2013-11-15 15:14:24 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-11-15 16:03:28 -0600

Rabin gravatar image

Seems you have unfinished updates, try running:

package-cleanup --cleandupes

As for your certificates, first check your clock - make sure is current. If it is ok, you can try and reinstall the root CA bundle

yum reinstall ca-certificates
edit flag offensive delete link more

Comments

After first command. The machine downloaded some package and went dark. I can only boot to climb now. How to alive this

highjo gravatar imagehighjo ( 2013-11-15 17:16:08 -0600 )edit

What do you mean by "went dark" - as you don't see the login screen after a reboot ?

Rabin gravatar imageRabin ( 2013-11-16 07:14:39 -0600 )edit

got black after some times as if it crashed. after 1h 30mn approximately the machine frozen then I had to hard boot it. when I did X windows doesn't start anymore. I logged in in command line did the package clean up again. this time It finished it. I also run the certificate reinstallation. It still doesn't start the X windows

highjo gravatar imagehighjo ( 2013-11-16 07:41:12 -0600 )edit

I don't see any package in the list your pasted that can cause this. You will need to check your logs/journal to see if any problem is mentioned there.

Rabin gravatar imageRabin ( 2013-11-16 13:13:29 -0600 )edit
1

answered 2013-11-20 02:29:44 -0600

highjo gravatar image

I reinstalled the fedora 19

edit flag offensive delete link more

Comments

And ? Did it get back to work ?

Rabin gravatar imageRabin ( 2013-11-20 04:48:01 -0600 )edit

yeah, it's a clean one. I had wiped a lot of things

highjo gravatar imagehighjo ( 2013-11-21 11:33:36 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-11-15 14:08:24 -0600

Seen: 326 times

Last updated: Nov 20 '13