Ask Your Question
3

How do I disable the GNOME Lock Screen?

asked 2013-11-25 10:47:34 -0500

Kalo Stoyanov gravatar image

updated 2017-01-13 15:04:24 -0500

mattdm gravatar image

Hey!

So.. I can't disable the GNOME lock screen. I tried turning it off via the Settings panel and the dconf-editor, but both tools say it's off when it actually isn't.

I tried googling it, but I couldn't find anything helpful. So.. Can you help me?

edit retag flag offensive close merge delete

Comments

2

Here, there are no icons on the desktop without special effort. What version of Fedora are you using?

randomuser gravatar imagerandomuser ( 2013-11-26 21:50:40 -0500 )edit

Um.. Yeah. Turns out I don't have icons on the Desktop :D. I'm a bit distracted as a person and usually I don't pay attention to things. When I posted this, I had. Now I don't have (it's been a couple of days) and when I think about it, I didn't have except for that time. Not sure why is that. I still can't disable the lock screen though

P.S. Thanks for the edit on the question

Kalo Stoyanov gravatar imageKalo Stoyanov ( 2013-11-28 07:19:48 -0500 )edit

Which version of GNOME are you using?

wilf gravatar imagewilf ( 2013-12-01 17:58:28 -0500 )edit

I'm using 3.8

Kalo Stoyanov gravatar imageKalo Stoyanov ( 2013-12-03 13:18:39 -0500 )edit

9 Answers

Sort by ยป oldest newest most voted
7

answered 2013-11-28 16:14:39 -0500

cjbayliss gravatar image

If you go into the "Activates" then type "settings" click on the icon that has a spanner and a screwdriver and says "Settings". When it has opened, click on the the icon that looks like a lock dial and says "Privacy". Now click on the item that says "Screen Lock" then click on the toggle switch next the text that says "Automatic Screen Lock". Press the button that says Close, and now the item that says "Screen Lock" should have "Off" next to it.

edit flag offensive delete link more

Comments

2

Yes! this is the correct answer.

Charles Wang gravatar imageCharles Wang ( 2013-11-28 20:55:24 -0500 )edit

Doesn't work for me. Same thing via dconf-editor - it shows that it's turned off when it actually isn't

Kalo Stoyanov gravatar imageKalo Stoyanov ( 2013-11-29 08:08:59 -0500 )edit
1

This answer is 100% correct. If that doesn't work, then it's a bug, and you should report it.

bochecha gravatar imagebochecha ( 2013-12-03 05:30:13 -0500 )edit

God knows how much time it will take. I was looking for a work-around :). Anyways, thanks

Kalo Stoyanov gravatar imageKalo Stoyanov ( 2013-12-03 13:22:55 -0500 )edit
1

It may be that your settings are corrupted. Try moving your .config dir to somewhere, then log out and in. And try what I said above and if that works then you may want to go through the old .config dir and keep the settings that you want. If it doesn't work then do what @bochecha said.

cjbayliss gravatar imagecjbayliss ( 2013-12-03 16:28:54 -0500 )edit
1

answered 2013-11-30 12:43:50 -0500

deusdara gravatar image

Hi

1) You need to open the gconfig editor by keying Alt-F2 and enter gconf-editor in the text box.

2) Next double-click on desktop to open the tree desktop.

3) Next double-click on gnome to open the tree gnome

4) Click once on lockdown and you'll see selections in the right-hand window. Tick the disable_ lock_screen box, close gconf2 and you are done.

edit flag offensive delete link more

Comments

1

gconf is not really supposed to be used in the latest versions of Gnome...

wilf gravatar imagewilf ( 2013-12-01 17:59:14 -0500 )edit

I'm using GNOME 3.8, so it has dconf. And yes, I did it already

Kalo Stoyanov gravatar imageKalo Stoyanov ( 2013-12-03 13:18:58 -0500 )edit
1

answered 2013-11-29 18:09:41 -0500

wilf gravatar image

updated 2013-12-01 18:02:39 -0500

You can always use the Caffeine extension to stop the screen auto-locking.


For the latest versions of Gnome you are supposed to use dconf not gconf to change settings.

So to 'lockdown' the screen as @deusdara suggests, either run:

gsettings set org.gnome.desktop.lockdown disable-lock-screen true

Or navigate to org.gnome.desktop.lockdown in dconf-editor and tick disable-lock-screen

The problem with this (I ain't checked much), is that this may only remove the 'lock' button from the menu, but it is still lockable via the keyboard shortcu, so it might still lock automatically.


Apart from the other suggested methods, there is always this:

sudo yum remove gnome-screensaver smiley

Surprisingly, this does not remove half the system as dependencies... But still is not much of an idea.


The top two ideas tested in Gnome 3.8.4 on Fedora 19 - Caffeine works brilliantly, while the second one vaguely works

edit flag offensive delete link more

Comments

IIRC, screensaver/lockscreen is now integrated into gnome-shell/mutter, you can't just remove it like you mentioned.

athmane gravatar imageathmane ( 2013-11-30 12:06:05 -0500 )edit

I know, but I was more wondering about the blank screen settings. I have more time to answer now, so shall Improve my answer a bit @athmane

wilf gravatar imagewilf ( 2013-12-01 17:54:13 -0500 )edit

I got "No Match for argument: gnome-screensaver" on the second method, and as for the Caffeine.. I'm not sure if I want to use it

P.S. Already tried with dconf, it doesn't work

Kalo Stoyanov gravatar imageKalo Stoyanov ( 2013-12-03 13:22:27 -0500 )edit

Caffene is really useful (I'm using 3.8 to) - it is just a small little button on the panel that you can click to stop the screen auto-locking. You can also get it to activate automatically when a application is opened, and do notifications etc. The second command would not be much of a good idea anyway, but you could list the possible packages with sudo yum list gnome*, and then remove the relevant one. Also, it would not work if you are using Xscreensaver.

wilf gravatar imagewilf ( 2013-12-03 13:56:12 -0500 )edit
0

answered 2016-04-27 02:55:49 -0500

In CentOS 7 this Screenlock can be disabled in 2 Steps...First Settings/Privacy/Screenlock off...AND Energy/Screen switchoff disable

edit flag offensive delete link more
0

answered 2017-08-15 20:23:24 -0500

I disabled the screen lock through the Privacy option (I just put the automatic screen lock on "off") but it keeps on locking when I am not active for a while. Any suggestion? Thank you in advance!

edit flag offensive delete link more
0

answered 2013-12-01 10:06:56 -0500

jmt gravatar image

You might also want to disable the Gnome Screen Shied which some of find annoying. There's a Gnome extension for that:

Disable Gnome Screen Shield

edit flag offensive delete link more
0

answered 2015-12-29 07:12:35 -0500

cube00 gravatar image

Posted my solution to similar question at Superuser.

edit flag offensive delete link more
0

answered 2016-07-29 16:33:34 -0500

I disabled mine with your tip and the following options.

org.gnome.desktop.screensaver idle-activation-enabled org.gnome.desktop.screensaver lock-enabled

org.gnome.desktop.screensaver ubuntu-lock-on-suspend

the last one may vary

edit flag offensive delete link more
0

answered 2017-08-15 20:20:44 -0500

I disabled the screen lock through the privacy (I just put the automatic screen lock on "off") but my screen keeps on locking if I am not actuve for a while. Any suggestion?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-11-25 10:47:34 -0500

Seen: 118,983 times

Last updated: Jan 13 '17