Ask Your Question
1

mysql login error

asked 2013-12-03 01:33:38 -0500

syedjavidali gravatar image

Hi,

I have installed mysql server in Fedora system, but when i login it is showing errors. I have attached the error below. Please let me know how to solve this issue.

sudo apt-get install mysql-admin mysql-client mysql-server

Reading Package Lists... Done Building Dependency Tree... Done E: Couldn't find package mysql-admin

sudo mysql -u root -p

Enter password: ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
1

answered 2013-12-03 02:06:29 -0500

mrunge gravatar image

We don't use apt-get like in Debian or Ubuntu, but yum. mysql was replaced by mariadb, which is compatible, but - frankly said - better.

yum install mariadb-server mariadb

Then you'll connect (you don't need sudo for that!)

mysql -u root

If you set a password for accessing your database, you'd use

mysql -u root -p
edit flag offensive delete link more
0

answered 2013-12-16 20:19:50 -0500

quantenselbstmord gravatar image

run : install maria DB is a fork of MySql su -c 'yum -y install mariadb-server'

start service : service mysqld start

config mariaDB : mysql_secure_installation

later accesing to mysql and type the pass your pass ( 3 step) : mysql -u root -p

its all

edit flag offensive delete link more
0

answered 2017-10-25 06:59:44 -0500

misharushi gravatar image

updated 2017-10-25 07:00:19 -0500

Install mysql MariaDB

sudo dnf install mariadb mariadb-server

To start MariaDB on Fedora, execute the following command:

systemctl start mariadb.service

To autostart MariaDB on Fedora, execute the following command:

systemctl enable mariadb.service

After you started MariaDB (do this only once), execute the following command:

/usr/bin/mysqlsecureinstallation

edit flag offensive delete link more
0

answered 2013-12-03 03:14:15 -0500

syedjavidali gravatar image

Still the same error...

edit flag offensive delete link more

Comments

what did you do?

mrunge gravatar imagemrunge ( 2013-12-03 04:00:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-12-03 01:33:38 -0500

Seen: 922 times

Last updated: Oct 25 '17