Ask Your Question
1

"ghost" screen connected with vga to laptop

asked 2014-01-04 11:08:29 -0500

muffin gravatar image

updated 2014-01-04 11:12:14 -0500

my fedora 20 thinks there is a second screen connected(via vga) to my laptop, but there really isnt.

[tom@faptop ~]$ xrandr Screen 0: minimum 320 x 200, current 2944 x 1080, maximum 8192 x 8192 LVDS1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm 1920x1080
60.0+ 1400x1050 60.0 1280x1024 60.0 1280x960
60.0 1024x768 60.0 800x600 60.3 56.2
640x480 59.9 VGA1 disconnected (normal left inverted right x axis y axis) HDMI1 disconnected (normal left inverted right x axis y axis) DP1 disconnected (normal left inverted right x axis y axis) VGA-1-2 connected 1024x768+1920+0 (normal left inverted right x axis y axis) 0mm x 0mm
1024x768 60.0
800x600
60.3 56.2 848x480 60.0 640x480 59.9 1024x768 (0x63) 65.0MHz h: width 1024 start 1048 end 1184 total 1344 skew 0 clock
48.4KHz v: height 768 start 771 end 777 total 806 clock
60.0Hz 800x600 (0x64) 40.0MHz h: width 800 start 840 end 968 total 1056 skew 0 clock
37.9KHz v: height 600 start 601 end 605 total 628 clock
60.3Hz 800x600 (0x65) 36.0MHz h: width 800 start 824 end 896 total 1024 skew 0 clock
35.2KHz v: height 600 start 601 end 603 total 625 clock
56.2Hz

I noticed this first when my workspaces icons were showing an extra space as if i was using dual screens, and when taking a desktop screenshot: https://dl.dropboxusercontent.com/u/28649112/terminals_002.png (dual screen pic)

when i open up the displays menu, it says "could not get screen information".

any idea of how to fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-01-04 12:33:18 -0500

This command will shut off output to the display:

xrandr --output VGA-1-2 --off

For something more permanent, you could add something like the below example in a xorg.conf snippet. Any .conf file in /etc/X11/xorg.conf.d/ will be loaded.

Section "Monitor"
    Identifier "VGA-1-2"
    Option "Ignore" "true"
    Option "Enable" "false"
EndSection

It's been a while since I've had to write xorg.conf stuff, so that might need some improvement. man xorg.conf has all the details.

edit flag offensive delete link more

Comments

thank you, the above helps, but this is more of a work around. But i would prefer to find the cause of this problem and fix that. for now i wont use the xorg fix you gave, untill we maybe find the cause.

muffin gravatar imagemuffin ( 2014-01-04 12:50:40 -0500 )edit

@muffin have you ever managed to solve this issue with a proper fix? EDIT: I asked too soon.. found this: https://bugzilla.redhat.com/show_bug.cgi?id=1173963

rando101 gravatar imagerando101 ( 2015-01-13 19:34:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-01-04 11:08:29 -0500

Seen: 1,144 times

Last updated: Jan 04 '14