Ask Your Question
1

Can't change background or see desktop icons on xfce after few weeks.

asked 2014-01-16 15:53:55 -0500

andyturner87 gravatar image

updated 2014-04-02 12:45:30 -0500

mether gravatar image

I'm on fedora 19, on a laptop, quite successfully other than this: My desktop image has gone, and so has the desktop icons and I can't right click on desktop.

Maybe an update did it?

EDIT: I am using Xfce, and it was all fine for a week or two...

edit retag flag offensive close merge delete

Comments

did you make any update before this issue?

williamjmorenor gravatar imagewilliamjmorenor ( 2014-01-30 23:10:06 -0500 )edit

Yes did yum update. Have since upgraded to F20, still same issues except that the background has changed to new default background! So i still cant change it. (it is actually set at something different)

andyturner87 gravatar imageandyturner87 ( 2014-02-02 18:43:09 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2014-01-18 20:06:05 -0500

sideburns gravatar image

Try this: log out and use ^Alt-F2 to open a text console. Log in as yourself, and run this command:

mv .config/xfce4 .config/xfce4.old

This will have the same effect as deleting your config, but you'll still have a backup copy. Then, log out and use ^Alt-F1 to go back to your GUI login screen. Log in, and Xfce will create a new config file with the default settings. If this works, there was something corrupt in your config; if not, let us know in a comment to this answer, and we can look further.

edit flag offensive delete link more

Comments

Ok well I can't use the alt button shortcuts as the f keys are not default on this machine and cant seem to change that (in linux at least) but I tried just clicking on terming, issuing the command then logging out then in, and it reset Xfce to default, so the original background is there but i still have all the other same problems.... cant change desktop image, right click on desktop, and still no icons lol.

andyturner87 gravatar imageandyturner87 ( 2014-01-28 15:54:32 -0500 )edit

From your Main Menu, go to Settings->Desktop and select the middle tab, the one marked Menus. The first item on the tab should be Desktop Menu, and under it should be "show applications menu on desktop right-click." Put a check in that box, close the window and you should be able to do what you want, although it's possible that you'll need to log out and back in. Good luck!

sideburns gravatar imagesideburns ( 2014-01-28 16:16:47 -0500 )edit

It's already checked. And when I try to change background image I can select different backgrounds but not actually set them! =(

andyturner87 gravatar imageandyturner87 ( 2014-01-29 17:59:10 -0500 )edit
0

answered 2015-10-10 11:01:55 -0500

ccpizz gravatar image

Most likely you installed an alternative desktop such as Gnome, or possibly, some Gnome apps such as Nautilus or Nemo which pulled in extra Gnome libraries.

If you are running under XFCE4 and happened to start Nautilus/Nemo without the --no-desktop, then an extra gnome desktop will be created on top of the XFCE desktop and your original desktop icons will either be hidden or not clickable.

The fix is to edit the Nautilus/Nemo launcher and append --no-desktop to the command line.

edit flag offensive delete link more
0

answered 2014-04-01 15:54:35 -0500

olddozen gravatar image

updated 2014-04-03 02:50:51 -0500

I have the same problem on Fedora 20. Not a show stopper but odd and inconvenient. I tried moving the config file as suggested with the same result as andyturner87. I then created a new user and copied the xfce4 config file from my normal user, the one with the inaccessible desktop, to the new user. The new user had my tailored panel but the desktop was accessible with all the correct icons. I did a bit of googling and found a similar issue which was solved by running the command:

xfdesktop

I tried this and it worked for me. Oh, once you have your desktop back don't forget to save the session when you exit else you'll lose it next time you log in.

edit flag offensive delete link more

Comments

just ran into the same problem on a kernel upgrade with f20 to 3.17.8-200, and xfdesktop 4.10.3 and XFce 4.10. also updated to NVIDIA-Linux-x86_64-346.35.run drivers (lenvolo W530 laptop with dock) symptoms were similar in that I had no desktop icons, nor background pictures, with default background except for a large white panel lower left that was in all workspaces. changing to solid colors had no effect.

simply running 'xfdesktop' reset everything to normal.

thanks!

grat gravatar imagegrat ( 2015-01-20 09:01:45 -0500 )edit

Upgraded f18->f20, xfdesktop run fixes the issue.

andriy gravatar imageandriy ( 2015-02-09 03:13:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-01-16 15:53:55 -0500

Seen: 7,125 times

Last updated: Apr 03 '14