Ask Your Question
1

Can't load proprietary nvidia driver (fails to initialize GLX extension).

asked 2014-01-18 09:42:39 -0500

ttomecek gravatar image

updated 2014-02-13 17:08:23 -0500

mether gravatar image

I've tried to install nvidia's proprietary drivers from rpm fusion recently but with no luck. Fortunately my system reached graphical environment. But I have found this in logs of X server:

[    39.807] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

Which resulted into:

$ glxinfo
name of display: :0
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".

This is pretty strange, because there is an information about successfully loaded nvidia driver several lines above in xorg's log:

[    37.874] (II) "glx" will be loaded by default.
[    37.874] (WW) "xwayland" is not to be loaded by default. Skipping.
[    37.874] (II) LoadModule: "glx"
[    37.902] (II) Loading /usr/lib64/nvidia/xorg/libglx.so
[    39.304] (II) Module glx: vendor="NVIDIA Corporation"
[    39.304]    compiled for 4.0.2, module version = 1.0.0
[    39.304]    Module class: X.Org Server Extension
[    39.304] (II) NVIDIA GLX Module  331.20  Wed Oct 30 17:36:48 PDT 2013
[    39.314] Loading extension GLX

I had to remove xorg.conf provided by xorg-x11-drv-nvidia because I couldn't reach graphics (it said "no screens found"). So now I don't have any xorg.conf and there is just 99-nvidia.conf in /etc/X11/xorg.conf.d/ which loads nvidia X driver I presume.

(this was happening on 3.12.5 and 3.12.7 kernel)

Did anyone have similar issue?

edit retag flag offensive close merge delete

Comments

I assume you have a system equipped with nvidia's Optimus technology; meaning, your CPU (Intel) has a builtin GPU capabilities, and you have an additional GPU from nvidia. If you want to use the nvidia GPU, you need to go into your BIOS settings, and turn off "Optimus" settings, and choose the Discrete (nvidia) video card as the default. Then, your rpmfusion-provided nvidia drivers will kick in and take it from there ; )

ILMostro gravatar imageILMostro ( 2014-02-03 16:02:52 -0500 )edit

Thanks for help I already figured it out. Unfortunately, my BIOS doesn't support disabling either of the GPUs.

ttomecek gravatar imagettomecek ( 2014-02-04 01:34:26 -0500 )edit

no problem; you might also want to keep track of the ongoing development with nouveau and prime, as nvidia announced recently only that they were going to support the development of Switchable Graphics (Optimus) on Linux platforms :D

ILMostro gravatar imageILMostro ( 2014-02-04 04:08:49 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-02-03 12:07:14 -0500

ttomecek gravatar image

The issue was that I had to explicitly specify nvidia GPU providing bus ID:

Section "Device"
       Identifier   "Videocard1"
       Driver       "nvidia"
       BusID       "PCI:1:0:0"        
EndSection

But in the end, I had to install bumblebee.

edit flag offensive delete link more
1

answered 2014-01-19 02:34:14 -0500

Gaurav Dighe gravatar image

I also got the errors. I wld recommend you to update the selinux-policy to 3.12.17 from 3.12.6. There's a bug in 3.12.6 version of selinux. It is not allowing to complete the installation. sudo setenforce 0 sudo setenforce 0 sudo yum update selinux-policy sudo setenforce 1

You need to first install kernel-devel package. Then reboot and then install akmod-nvidia.

Again reboot...then from rpmfusion, install hardware acceleration.

it ran and is working beautyfully on my machine.

  • List item
edit flag offensive delete link more

Comments

Thanks. Will try.

ttomecek gravatar imagettomecek ( 2014-01-19 11:12:37 -0500 )edit
0

answered 2014-02-03 16:33:08 -0500

sergiomb gravatar image

1 - check /etc/X11/xorg.conf.d/ for nvidia file which set GLX path , Nvidia have a different GLX then nouveau 2 - have you installed xorg-x11-drv-nvidia-libs ?

edit flag offensive delete link more

Comments

that file you're referring to is actually located in /usr/lib64/nvidia/xorg/libglx.so, which the OP pointed out is loaded at startup: [ 37.902] (II) Loading /usr/lib64/nvidia/xorg/libglx.so

ILMostro gravatar imageILMostro ( 2014-02-03 17:02:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-01-18 09:42:39 -0500

Seen: 30,176 times

Last updated: Feb 03 '14