Ask Your Question
1

"alloc magic is broken" after update

asked 2014-01-18 11:11:34 -0500

david3141 gravatar image

updated 2014-01-18 21:05:05 -0500

FranciscoD_ gravatar image

Hello,

I recently made an update to linux 3.12.7-300.fc20.x86_64. Now, every time I try to select the corresponding entry in grub I get an "alloc magic is broken at <some address="">". I can still select the 3.12.6-300 entry and everything works fine then.

I'm a bit clueless how to approach this problem, the above error message gets me all kinds of possible error causes when I google it and nothing seems to be related to anything I did. Any ideas?

Thanks in advance for your help!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-01-18 21:03:57 -0500

FranciscoD_ gravatar image

Looks like a reported issue:

https://bugzilla.redhat.com/show_bug.cgi?id=976768

Please follow up at the bug tracker.

edit flag offensive delete link more

Comments

Thanks a lot. I'm not really sure the initial bug report does describe the same problem (sounds to me like the grub menu isn't even entered), but some users in the comments definitely experienced the same issue. The solution was to edit /boot/grub2/grub.cfg by replacing "initrd" with "initrdefi" like described in comment #18. Thanks again!

david3141 gravatar imagedavid3141 ( 2014-01-19 05:23:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-01-18 11:11:34 -0500

Seen: 1,767 times

Last updated: Jan 18 '14