Ask Your Question
4

Can anyone helpme to install LAMP in fedora 20

asked 2014-01-23 09:19:20 -0500

melviii100 gravatar image

updated 2014-01-23 18:50:03 -0500

FranciscoD_ gravatar image

Am getting 100 s of errors while doing "yum install httpd php mysql mysql-server " see this, (i don't know to put below code in separate code list, because when i copy and paste my entire code only one line is coming in separate code, otherse are coming like below) if you can help me, give the required codes, i will try and will post the error. last 5-6 days am struggle with this probs,now only one solution- uninstall fedora. before that last try!

Loaded plugins: langpacks, refresh-packagekit
Package 1:mariadb-5.5.34-2.fc20.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package httpd.x86_64 0:2.4.6-6.fc20 will be installed
---> Package mariadb-server.x86_64 1:5.5.34-2.fc20 will be installed
---> Package php.x86_64 0:5.5.7-1.fc20 will be installed
--> Processing Dependency: php-cli(x86-64) = 5.5.7-1.fc20 for package: php-5.5.7-1.fc20.x86_64
--> Finished Dependency Resolution
Error: Package: php-5.5.7-1.fc20.x86_64 (updates)
           Requires: php-cli(x86-64) = 5.5.7-1.fc20
           Installed: php-cli-5.5.8-1.fc20.remi.x86_64 (@remi)
               php-cli(x86-64) = 5.5.8-1.fc20.remi
           Available: php-cli-5.5.6-1.fc20.x86_64 (fedora)
               php-cli(x86-64) = 5.5.6-1.fc20
           Available: php-cli-5.5.7-1.fc20.x86_64 (updates)
               php-cli(x86-64) = 5.5.7-1.fc20
 You could try using --skip-broken to work around the problem
** Found 21 pre-existing rpmdb problem(s), 'yum check' output follows:
1:NetworkManager-0.9.9.0-24.git20131003.fc20.x86_64 has missing requires of NetworkManager-glib(x86-64) = ('1', '0.9.9.0', '24.git20131003.fc20')
php-bcmath-5.5.8-1.fc20.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.5.8', '1.fc20.remi')
php-cli-5.5.8-1.fc20.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.5.8', '1.fc20.remi')
php-gd-5.5.8-1.fc20.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.5.8', '1.fc20.remi')
php-gmp-5.5.8-1.fc20.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.5.8', '1.fc20.remi')
php-mbstring-5.5.8-1.fc20.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.5.8', '1.fc20.remi')
php-mcrypt-5.5.8-1.fc20.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.5.8', '1.fc20.remi')
php-pdo-5.5.8-1.fc20.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.5.8', '1.fc20.remi')
php-pecl-apcu-4.0.2-2.fc20.remi.x86_64 has missing requires of /usr/bin/pecl
php-pecl-igbinary-1.1.2-0.7.gitc35d48f.fc20.x86_64 has missing requires of /usr/bin/pecl
php-pecl-jsonc-1.3.3-1.fc20.remi.5.5.x86_64 has missing requires of /usr/bin/pecl
php-pecl-memcache-3.0.8-2.fc20.x86_64 has missing requires of /usr/bin/pecl
php-pecl-memcached-2.2.0-0.1.b1.fc20.remi.5.5.x86_64 has missing requires of /usr/bin/pecl
php-pecl-mongo-1.4.5-1.fc20.remi.5.5.x86_64 has missing requires of /usr/bin/pecl
php-pecl-msgpack-0.5.5-4.fc20.x86_64 has missing requires of /usr/bin/pecl
php-pecl-sqlite-2.0.0-0.4.svn332053.fc20.remi.5.5.x86_64 has missing requires of ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2014-01-23 09:51:02 -0500

muffin gravatar image

updated 2014-01-23 09:51:56 -0500

try installing step by step, to get a better view on what actually installs, and works, and what doesnt.

what i did first:

2. Yum update
3. yum install httpd
4. service httpd start **or** systemctl enable httpd.service
5. yum install php php-common
6. yum install php-pecl-apc php-cli php-pear php-pdo php-mysqlnd
7. (make a page in /var/www/html/test.php <? phpinfo(); ?>     )
8. service httpd restart
9. service httpd status

then test if you can open that page on your localhost, (in firefox) if it says could not connect, go to your firewall settings, tab zones > public > services > make sure http is highlighted.

1. Yum install mariadb mariadb-server
2. systemctl start mysqld.service
3. mysql_secure_installation
4. yum install phpMyAdmin

follow all installation steps(mysql_secure_installation configures the root password for mariadb(which is your sql) phpAdmin is a webinterface for your management of mysql/mariadb.

for more information you could google more on these subjects.

see where this gets you and what you get/dont get and what works and what doesnt.

edit flag offensive delete link more

Comments

yum install php php-common - got following error-> Error: Package: php-5.5.7-1.fc20.x86_64 (updates) Requires: php-cli(x86-64) = 5.5.7-1.fc20

Found 20 pre-existing rpmdb problem(s), 'yum check' output follows: php-bcmath-5.5.8-1.fc20.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.5.8', '1.fc20.remi') php-cli-5.5.8-1.fc20.remi.x86_64 has missing requires of php-common(x86-64) = ('0', '5.5.8', '1.fc20.remi')

melviii100 gravatar imagemelviii100 ( 2014-01-23 10:46:18 -0500 )edit

You need to remove all packages that you installed from remi repository

mether gravatar imagemether ( 2014-01-23 10:48:23 -0500 )edit

how , i don't know what i installed from remi. how we know that.

melviii100 gravatar imagemelviii100 ( 2014-01-23 10:59:56 -0500 )edit

You don't know the packages you installed yourself? rpm -qa | grep remi to list them and use yum to remove them

mether gravatar imagemether ( 2014-01-23 11:08:21 -0500 )edit

can't erase some remi,

ERROR with transaction check vs depsolve:
php-common(x86-64) = 5.5.8-1.fc20.remi is needed by (installed) php-cli-5.5.8-1.fc20.remi.x86_64
php-common(x86-64) = 5.5.8-1.fc20.remi is needed by (installed) php-process-5.5.8-1.fc20.remi.x86_64
php-common(x86-64) = 5.5.8-1.fc20.remi is needed by (installed) php-xml-5.5.8-1.fc20.remi.x86_64
melviii100 gravatar imagemelviii100 ( 2014-01-23 11:31:23 -0500 )edit
0

answered 2014-01-23 10:32:41 -0500

aeperezt gravatar image

updated 2014-01-23 10:33:23 -0500

Your have remi repository that is what cause the issue since remi carries php version that conflict with fedora standard php version, you could install lamp with:

yum groupinstall " Web Server" --disablerepo=remi

if you want to have the php version that remi repo provides then you can update php after that.

Yum update php

good luck

edit flag offensive delete link more

Comments

Got follwoing error-> yum groupinstall "Web Server" --disablerepo=remi Loaded plugins: langpacks, refresh-packagekit

Error getting repository data for remi, repository not found

melviii100 gravatar imagemelviii100 ( 2014-01-23 10:54:36 -0500 )edit

look into /etc/yum.repo.d/ to see if you find remi.repo if it does not exists then use yum groupinstall "Web Server". How ever if you have error like "php-common(x86-64) = 5.5.8-1.fc20.remi is needed by (installed) php-cli-5.5.8-1.fc20.remi.x86_64" then you had installed remi repo before and removed try to do yum remove php* to eliminate all php previus installed. then do the yum groupinstall "Web Server". Good luck

aeperezt gravatar imageaeperezt ( 2014-01-28 11:00:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-01-23 09:19:20 -0500

Seen: 3,655 times

Last updated: Jan 23 '14